idevaffiliate Coupons

11 months 6 days ago #333264 by krileon
Replied by krileon on topic idevaffiliate Coupons
The coupon functionality is specifically the following.

www.idevlibrary.com/docs/Coupon_Code_Commissioning.pdf

Unless that API has changed it should be working as we're still passing along the field value if configured or the first coupon applied to a basket. It will not work if multiple coupons are applied as that API doesn't allow for that.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 months 6 days ago #333276 by wjgadmin
Replied by wjgadmin on topic idevaffiliate Coupons
In this case (and all for us), there is only 1 coupon code. We contacted idev and they tested everything as we had it setup. It worked without any issues. They said the only reason should be that the code isn't being passed. Is there anyway we can test this? I need to make sure it is being passed so we can use the coupon codes accordingly. Thank you

Please Log in to join the conversation.

11 months 6 days ago #333277 by krileon
Replied by krileon on topic idevaffiliate Coupons
Do they have a log on their end that logs inbound API requests? You'd then be able to see if the coupon code was included. Are you using a coupon code or a coupon that's always applied or are you trying to send a field value? Try setting it to send a field value and set the field to your coupon code and see if that goes through.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 months 4 days ago #333288 by wjgadmin
Replied by wjgadmin on topic idevaffiliate Coupons
I've contacted them regarding the log and awaiting response. Unfortunately after trying the field option as well, it is still not working. It seems there may be an issue with the information being passed to idev. Everything is working properly when the standard linking procedure is used, but the coupon code will not get recognized no matter what I try.

Hopefully we can find a resolution, thank you.

Please Log in to join the conversation.

11 months 3 days ago #333302 by krileon
Replied by krileon on topic idevaffiliate Coupons
I don't know what to suggest. We're sending it according to their API so unless the API changed I don't see why it shouldn't work. When originally implemented this was thoroughly tested as working so if not working now it's likely due to an API change on their end.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

11 months 3 days ago #333303 by krileon
Replied by krileon on topic idevaffiliate Coupons
Ah, believe I see the problem. The wrong data is being sent for the coupon! Have added a bug ticket and am working on a fix.

forge.joomlapolis.com/issues/9154


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: wjgadmin

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.193 seconds