Bast way to block hotmail/outlook/live email addresses from registration

4 months 1 week ago #329566 by boyjahq
Email source code shows

Content-Type: text/html; charset=UTF-8

Please Log in to join the conversation.

4 months 4 days ago #329569 by krileon
My guess is there is potentially broken HTML in the email. Many email providers will attempt to fix the broken HTML, but aren't always successful in doing so. Please provide the full language string for your email and will see if there's any formatting problems in it. You can typically easily confirm this by reverting back to the default language key YOUR_REGISTRATION_IS_PENDING_APPROVAL_MESSAGE and seeing if it displays fine in hotmail.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 months 3 days ago #329577 by boyjahq
The problem seems to be associated with Content-Transfer-Encoding. The one causing these problems seems to be
Content-Transfer-Encoding: quoted-printable.

Most email services are good at processing out the quoted-printable codes, but Microsoft-based emails are apparently maintaining a kind of legacy approach that does not correct for these. The internet is FULL of complaints about this issue. Even though PHPMailer is set to 8bit by default, it appears to be changed to quoted-printable by mail servers such as Microsoft. The result is that any line that of text that exceeds 76 characters gets something like

"=
=3D=0A="

inserted at the 76th character spot.

After days of testing and research, I have discovered that I can solve this issue if I change the following setting in CBPHPMailer.php from "8bit" to "base64":
/**
     * The message encoding.
     * Options: "8bit", "7bit", "binary", "base64", and "quoted-printable".
     * @var string
     */
    public $Encoding = 'base64';

Set to base64, properly formatted emails are delivered to hotmail and outlook email users.

Does that make sense? And more importantly, will our modified message encoding setting be removed anytime we update Community Builder? If so, is there some way that we can keep it in place?

Please Log in to join the conversation.

4 months 3 days ago #329581 by krileon

Does that make sense?

No idea, I'm not an expert when it comes to mail servers.

And more importantly, will our modified message encoding setting be removed anytime we update Community Builder?

Yes, of course. Any modifications to core code will be lost on update.

If so, is there some way that we can keep it in place?

Will review needing to add a parameter to let you select the encoding. For now I suggest making a note to reapply your change after an update.

forge.joomlapolis.com/issues/8964

Since this is specifically a hotmail problem we might be able to just apply the encoding change automatically internally, but will also explore adding a parameter to change the encoding.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: boyjahq

Please Log in to join the conversation.

3 months 3 weeks ago #329654 by boyjahq

Since this is specifically a hotmail problem...


Technically, it is not only hotmail. We can see this problem with all Microsoft related email accounts: hotmail, outlook and all "live" email addresses (live.com, live.jp, live.nl, live.co.uk, etc.). We have also seen similar issues with emails from certain university email accounts where we can see in the headers that they are using Microsoft email servers but they are associated with the domain name of the university.
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

3 months 6 days ago #329839 by boyjahq
What mailer setting does Joomlapolis use on the website? PHP Mail, sendmail or SMTP?

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.247 seconds

Facebook Twitter LinkedIn