Skip to Content Skip to Menu

CB Captcha + CB 1.2.3 sporadic problems

13 years 6 months ago #146479 by gianpietro
CB Captcha + CB 1.2.3 sporadic problems was created by gianpietro
Hi,

I just installed the last version of CB Captcha in CB 1.2.3, and I see that sometimes the image is not shown. The image fails to appear sporadically, and when I reload the page using F5 it usually appears.

Cache is globally disabled; where should I start looking?

Thanks!
Gianpietro




Post edited by: gianpietro, at: 2010/11/17 15:39
Attachments:

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68625
  • Thanks: 9109
  • Karma: 1434
13 years 6 months ago #146492 by krileon
Replied by krileon on topic Re:CB Captcha + CB 1.2.3 sporadic problems
Could you please see help us help you within my signature? We need many more details concerning your hosting environment. We've had a few other users with similar issues and need more information to pinpoint the problem as we suspect is host related (possibly a bad PHP GD module).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

13 years 6 months ago #146707 by gianpietro
Replied by gianpietro on topic Re:CB Captcha + CB 1.2.3 sporadic problems
Hi,

Thanks for your answer, I checked the section and tried many things and still nothing, so here's more information:

- PHP Version 5.3.2-1ubuntu4.5
- CB Version 1.2.3
- Joomla Version 1.5.21
- Problem is that sometimes the captcha image shows no letters (image appears but with no letters on it), then I refresh the page and they appear.
- Link to test: pentatonico.com/index.php?option=com_comprofiler&task=registers (keep pressing F5 and sometimes you will not see the letters)
- There are no errors related to the plugin, just this one: "Warning: Cannot modify header information - headers already sent by (output started at [serverpath]/components/com_sef/sef_incl.php:0) in [serverpath]administrator/components/com_comprofiler/library/cb/cb.session.php on line 74 (same on line 149)
- Using SEF Advance 2008, but problem persists when disabling it.
- All is fresh install.
- Issue is present in Firefox and IE8 as far as I tested.
- Issue is present using GD2, ImageMagick or NetPBM (i don't have GD1 installed, not sure how to install it)

Thanks!
Gianpietro

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68625
  • Thanks: 9109
  • Karma: 1434
13 years 6 months ago #146869 by krileon
Replied by krileon on topic Re:CB Captcha + CB 1.2.3 sporadic problems
Have you tried with both settings of Captcha images and sound mode:?

- Issue is present using GD2, ImageMagick or NetPBM (i don't have GD1 installed, not sure how to install it)

Only GD is used for the rendering, so it could be a problem with the compiled GD library still. It's also possible as to how its rendering letters as they could be rendered "off-image" perhaps. Will require further investigation. If possible please provide your exact GD library version (contact host or see PHP information page).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

13 years 6 months ago #146872 by gianpietro
Replied by gianpietro on topic Re:CB Captcha + CB 1.2.3 sporadic problems
Hi,

I just tried with the "image+sound" setting but still seeing the issue from time to time as before.

My hosting is VPS Ubuntu, so I installed the library myself using apt-get. I have tried reinstalling it also.

Phpinfo regarding GD is below, I'm using version 2.0.

thanks!
Gianpietro

GD Support enabled
GD Version 2.0
FreeType Support enabled
FreeType Linkage with freetype
FreeType Version 2.3.11
T1Lib Support enabled
GIF Read Support enabled
GIF Create Support enabled
JPEG Support enabled
libJPEG Version 6b
PNG Support enabled
libPNG Version 1.2.42
WBMP Support enabled

Directive Local Value Master Value
gd.jpeg_ignore_warning 0 0
Attachments:

Please Log in or Create an account to join the conversation.

13 years 5 months ago #147779 by gianpietro
Replied by gianpietro on topic Re:CB Captcha + CB 1.2.3 sporadic problems
Hi, I just installed CB 1.3 and the updated Captcha plugin, but problem persists.

I agree that this may be a problem related to the server, but could you give me any clue on where to check? I have total control.

Thanks!
Gianpietro

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum

Facebook Twitter LinkedIn