Contact form doesn't work when I'm logged in

5 years 7 months ago #254334 by peepiolee
My joomla version : 3.3.6
My Community Builder version : 2.0.3
My PHP version : 5.4.34
My MYSQL version : 5.1.73-2


I have an issue whith my contact forms.
When a public wants to send an email to a registered user, he can and the mail is correctly sent. I've allowed the public contact form on the users' profile.

But when I try the same thing when I'm logged in (like a super user or a registered member), I can access to the form - nothing wrong so far - but I got a "you are not allowed to view this content" error.

Please Log in to join the conversation.

5 years 7 months ago #254335 by nant

peepiolee wrote: My joomla version : 3.3.6
My Community Builder version : 2.0.3
My PHP version : 5.4.34
My MYSQL version : 5.1.73-2


I have an issue whith my contact forms.
When a public wants to send an email to a registered user, he can and the mail is correctly sent. I've allowed the public contact form on the users' profile.

But when I try the same thing when I'm logged in (like a super user or a registered member), I can access to the form - nothing wrong so far - but I got a "you are not allowed to view this content" error.


I cannot replicate on a clean Joomla 3.3.6 / CB 2.0.3 environment.

If you can, then please provide exact steps to replicate and I will retest.

Please Log in to join the conversation.

5 years 7 months ago #254346 by peepiolee
Replied by peepiolee on topic Contact form doesn't work when I'm logged in
It's a little hard to replicate cause my CB is in french, so I will try to translate it in english.

In the configuration panel :

Email management: display email form link
Public email form: yes
Emails sent by: admin email, with reply to the user
Email link: yes

Also, I'm using the SMTP protocol (I don't have the choice), so maybe it comes from here.

Please Log in to join the conversation.

5 years 7 months ago #254357 by nant

peepiolee wrote: It's a little hard to replicate cause my CB is in french, so I will try to translate it in english.

In the configuration panel :

Email management: display email form link
Public email form: yes
Emails sent by: admin email, with reply to the user
Email link: yes

Also, I'm using the SMTP protocol (I don't have the choice), so maybe it comes from here.


I really need instructions to replicate off a clean install.

So:
1. Install Joomla 3.3.6
2. Install CB 2.0.3
3.
4.
5.

If you can replicate based on this and provide a list, then we will spend some time.
Otherwise I cannot replicate the issue on my test sites.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.468 seconds

Facebook Twitter LinkedIn