Updating UddeIM 3.4 >4.0

5 months 1 day ago #311398 by ggreybeard
Hi,

My site is on Joomla 3.9.4 and I am updating extensions following a failed attempt to move from PHPv5.6.36 to PHP7.x

When I attempted to update UDDeIM from v3.4 to v4.0 I received the message:

Warning: require_once(/home/(website address)/components/com_uddeim/uddeimlib38.php): failed to open stream: No such file or directory in /home/(website address)/components/com_uddeim/uddeimlib.php on line 44


The PM system failed and was unavailble. I retrieved it by restoring Joomla to its previous backup copy, so I am back on 3.4 again.

Can anyone advise how I can achieve the update?
5 months 1 day ago #311400 by slabbi
Something went wrong during the update. I assume that not all files have been copied, so some files are missing in
/components/com_uddeim/

You can unpack the installation archive and copy the missing file
uddeimlib38.php
in the folder mentioned above.

Or you can uninstall uddeIM and reinstall it using the web installer or local installer.

uddeIM & uddePF Development
Google+ profile: plus.google.com/u/0/b/117839921924782901705/
CB Language Workgroup
CB 3rd Party Developer
The following user(s) said Thank You: ggreybeard
5 months 1 day ago #311416 by ggreybeard
Thank you for your response, Slabbi.
I will proceed with one of your options.
:cheer:
Moderators: beatnantslabbikrileon
Time to create page: 0.366 seconds
Facebook Twitter Google LinkedIn