Session write error and other problems

13 years 5 months ago #65096 by Camee
Hello!

First of all, sorry for my bad english :blush:

I get a "Session write error" if I click on "Register" and "Forgot password?" in the CB-Login module. Nobody can register on my site, but I can manually insert new user in the userlist. Do you have an idea what I'm making wrong?

I have also problems with the german informal language plugin. I installed and published it with CB Pluginmanager. After that I disabled the default english language plugin. But everything in the backend and the frontend stayed in english. Perhaps I forgot something?

Thank you for your answer and suggestions.
Greetings from Austria,
Camee

Please Log in to join the conversation.

13 years 5 months ago #65098 by Friik
Replied by Friik on topic Re:Session write error and other problems
About your german language plugin: I never got that working as it is supposed to be as well. That's why I renamed and replaced the files in the default_language directory. Rename german.php to default_language.php and replace the calendar-locals.js with the one from the plugin. This way German becomes your default language, even though it is listed as "default language (English)" in backend^^.

Please Log in to join the conversation.

13 years 5 months ago #65101 by KurtSteiner
Replied by KurtSteiner on topic Re:Session write error and other problems
Camee wrote:

Hello!

First of all, sorry for my bad english :blush:

I get a "Session write error" if I click on "Register" and "Forgot password?" in the CB-Login module. Nobody can register on my site, but I can manually insert new user in the userlist. Do you have an idea what I'm making wrong?



Hello and thank your for the feedback,

first of all, the session write error seems to be not CB related.

I have seen this only one time in my Joomla live, when my server had no more diskspace to write the session information on the server HDD...

Camee wrote:

...I have also problems with the german informal language plugin. I installed and published it with CB Pluginmanager. After that I disabled the default english language plugin. But everything in the backend and the frontend stayed in english. Perhaps I forgot something?

Thank you for your answer and suggestions.
Greetings from Austria,
Camee


Here i think i can help.

I tested the german informal and german formal plugs before RC - so i´m sure we can get them working.

1.) doublecheck !
Which JOOMLA language is installed

2.) which JOOMLA language is published


Remember, the installed (second) CB language is only active if the related joomla language is active.

In your case: german informal


3.) If your joomla language is german informal and it is published, doublecheck which folder it uses.

I have seen joomla german informal translations uses the folder germani other uses german.

4.) Nick offered two german informal language packs.
please doublecheck and use the one which creates the same folder as you Joomla language (german or germani)



If you follow this, i´m sure you will get it working.

Please come back and report here if t works or not - this could help others with similar challenges

:)

Friik wrote

About your german language plugin: I never got that working as it is supposed to be as well. That's why I renamed and replaced the files in the default_language directory. Rename german.php to default_language.php and replace the calendar-locals.js with the one from the plugin. This way German becomes your default language, even though it is listed as "default language (English)" in backend^^.


Hello Friik,
yes, this workarround works - but it is only the half way.

the localization comes with the calandar.js so you must do severall changes here too.

sunny regards from Germany

BERND (Kurt Steiner)

Please Log in to join the conversation.

13 years 5 months ago #65103 by Camee
Replied by Camee on topic Re:Session write error and other problems
Hello Kurt!

Thank's for your answer. You solved my language plugin problem :) In deed, I installed the wrong version. After I checked which sitelanguage my Joomla! has, I noticed that I choosed German formal, not informal. Now I installed the german formal plugin and it works :silly:

But the "Session write error" is still there :( I checked my space on the server from my provider. I rent 2 GB and I use only 26 MB of it.

Maybe it's a template problem? I have the Dimensions template from RocketTheme and it seems, that a few components and modules doesn't work with one of the integrated functions like RokMooMenu or RokSlide. Here is the description of Dimensions: www.rockettheme.com/Templates/Available_Templates/Dimensions_-_Nov_07_Joomla_Templates/

Probably it's a problem with another plugin or component I installed on my site?

Here's the link to my site: www.sigma-versand.at (it's only a testdomain)

By the way: the original Login module from Joomla! works without problems on my site.

I would be deeply grateful if you could help me.

Camee

Edit: Two more possibilities:
1. I don't use SEF
2. The site and the database are on different servers.

Post edited by: Camee, at: 2008/06/08 20:31

Please Log in to join the conversation.

13 years 5 months ago #65105 by KurtSteiner
Replied by KurtSteiner on topic Re:Session write error and other problems
Camee wrote:

Hello Kurt!

Thank's for your answer. You solved my language plugin problem :) In deed, I installed the wrong version. After I checked which sitelanguage my Joomla! has, I noticed that I choosed German formal, not informal. Now I installed the german formal plugin and it works :silly:


Very good news !!!

Camee wrote:

But the "Session write error" is still there :( I checked my space on the server from my provider. I rent 2 GB and I use only 26 MB of it.

Maybe it's a template problem? I have the Dimensions template from RocketTheme and it seems, that a few components and modules doesn't work with one of the integrated functions like RokMooMenu or RokSlide. Here is the description of Dimensions: www.rockettheme.com/Templates/Available_Templates/Dimensions_-_Nov_07_Joomla_Templates/

Probably it's a problem with another plugin or component I installed on my site?

Here's the link to my site: www.sigma-versand.at (it's only a testdomain)

By the way: the original Login module from Joomla! works without problems on my site.

I would be deeply grateful if you could help me.

Camee

Edit: Two more possibilities:
1. I don't use SEF
2. The site and the database are on different servers.

Post edited by: Camee, at: 2008/06/08 20:31



ok, ROK templates, i use them but i don´t like the problems they come with ... ;)

Are you sure that you are using the CB_login_module on your frontpage which is part of CB 1.2 ?

CB 1.2 RC + german formal should show:

Benutzername oder Passwort verloren?
Noch nicht dabei? Hier registrieren!


but your site shows:

Password vergessen?
Hier registrieren!


I believe you are using a different version :whistle:

Please doublecheck and report back.

sunny regards from Germany

BERND (Kurt Steiner)

Please Log in to join the conversation.

13 years 5 months ago #65106 by beat
Regarding "session write error": this is a captcha issue, right ?

If yes,:

1) please check my reply here:

www.joomlapolis.com/component/option,com_joomlaboard/Itemid,38/func,view/id,64465/catid,53/

2) are you on php4 ? if yes, can you get php5 on your host ?

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.195 seconds

Facebook Twitter LinkedIn