Skip to Content Skip to Menu

Captcha 2.3 installation error

13 years 3 months ago #154117 by danieledecia
Captcha 2.3 installation error was created by danieledecia
Hi,
I just upraged to CB 1.4, but I still got a problem installing the pursued captcha module.
Trying to install it from the CB plugin management I get this message:

Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: Entity: line 1: parser error : Start tag expected, '<' not found in /administrator/components/com_comprofiler/library/cb/cb.installer.php on line 169

Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: in /administrator/components/com_comprofiler/library/cb/cb.installer.php on line 169

Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: ^ in /administrator/components/com_comprofiler/library/cb/cb.installer.php on line 169

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /administrator/components/com_comprofiler/library/cb/cb.installer.php:169 Stack trace: #0 /administrator/components/com_comprofiler/library/cb/cb.installer.php(169): SimpleXMLElement->__construct('???????Mac OS X...') #1 /administrator/components/com_comprofiler/library/cb/cb.installer.php(144): cbInstaller->isPackageFile('/tmp/install_4d...') #2 /administrator/components/com_comprofiler/library/cb/cb.installer.php(66): cbInstaller->findInstallFile() #3 /administrator/components/com_comprofiler/controller/controller.default.php(2788): cbInstaller->upload('/tmp/plug_cbcap...') #4 /administrator/components/com_comprofiler/controller/controller.default.php(333): installPluginUpload() #5 /administrator/components/com_comprofiler/admin.comprofiler.controller.php(104): require_once('/administrator/...') #6 /administrator/components/com_comprofiler/admin.comprofiler.controller.php(217): _CBloadController('default') #7 /administrator/c in /administrator/components/com_comprofiler/library/cb/cb.installer.php on line 169

Please, give us some help.

Please Log in or Create an account to join the conversation.

  • oates
  • oates
  • OFFLINE
  • Posts: 10
  • Thanks: 1
  • Karma: 0
13 years 3 months ago #155273 by oates
Replied by oates on topic Re: Captcha 2.3 installation error
I have an error likewise:


ERROR: Could not find an XML setup file in the package.

Now, I have read and searched the forum and an well aware of the ultra-annoying 'people trying to install a plugin from the joomla install page' issue.

I am trying to install from the CB plugin page.

background:

It worked fine installing to Joomla 1.0.15

I can't get it to install to Joomla 1.5.22

both sites on same server so it isn't php related.

I checked directory permission in help / system info
read all posts and made sure component plugin directories 777 etc.
tried kicking site out of legacy 1.0 mode and installing
tried pretty much everything, would appreciate if anyone can help, just purchased for this reason.

BTW - I did this because strangely, 100's of people a day were creating accounts, even though email verification is checked and moderation on, I still see their accounts in the DB regardles, even after rejecting accounts. I assume this was due to some security issues with 1.2

Thanks again.

Please Log in or Create an account to join the conversation.

  • nant
  • nant
  • OFFLINE
  • Posts: 25531
  • Thanks: 1830
  • Karma: 877
13 years 3 months ago #155287 by nant
Replied by nant on topic Re: Captcha 2.3 installation error
CB Captcha plugin is a CB plugin not a Joomla package.

FAQ articles address this issue (guess very few actually read them ...).

Please Log in or Create an account to join the conversation.

  • nant
  • nant
  • OFFLINE
  • Posts: 25531
  • Thanks: 1830
  • Karma: 877
13 years 3 months ago #155288 by nant
Replied by nant on topic Re: Captcha 2.3 installation error
@ danieledecia: when do you get this exactly?

Please Log in or Create an account to join the conversation.

13 years 3 months ago #155301 by danieledecia
Replied by danieledecia on topic Re: Captcha 2.3 installation error
Hi,
I just tried to repeat the installation now, and choosing:
- Plugin Management
- Install new plugin - Upload package file (plug_cbcaptcha.zip)
I got the same message:

Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: Entity: line 1: parser error : Start tag expected, '<' not found in /administrator/components/com_comprofiler/library/cb/cb.installer.php on line 169

Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: in /administrator/components/com_comprofiler/library/cb/cb.installer.php on line 169

Warning: SimpleXMLElement::__construct() [function.SimpleXMLElement---construct]: ^ in /administrator/components/com_comprofiler/library/cb/cb.installer.php on line 169

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /administrator/components/com_comprofiler/library/cb/cb.installer.php:169 Stack trace: #0 /administrator/components/com_comprofiler/library/cb/cb.installer.php(169): SimpleXMLElement->__construct('???????Mac OS X...') #1 /administrator/components/com_comprofiler/library/cb/cb.installer.php(144): cbInstaller->isPackageFile('/tmp/install_4d...') #2 /administrator/components/com_comprofiler/library/cb/cb.installer.php(66): cbInstaller->findInstallFile() #3 /administrator/components/com_comprofiler/controller/controller.default.php(2788): cbInstaller->upload('/tmp/plug_cbcap...') #4 /administrator/components/com_comprofiler/controller/controller.default.php(333): installPluginUpload() #5 /administrator/components/com_comprofiler/admin.comprofiler.controller.php(104): require_once('/administrator/...') #6 /administrator/components/com_comprofiler/admin.comprofiler.controller.php(217): _CBloadController('default') #7 /administrator/c in /administrator/components/com_comprofiler/library/cb/cb.installer.php on line 169

could you please give me an help? I buyed this module and it sucks a lot since now.

thanks

Please Log in or Create an account to join the conversation.

  • nant
  • nant
  • OFFLINE
  • Posts: 25531
  • Thanks: 1830
  • Karma: 877
13 years 3 months ago #155304 by nant
Replied by nant on topic Re: Captcha 2.3 installation error

danieledecia wrote: Mac OS X...'
could you please give me an help? I buyed this module and it sucks a lot since now.

thanks


Mac OS X...

You are obviously on a MAC and is magically puts a Max OS folder in every zip you download!

You need to remove it, rezip and reinstall.

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum

Facebook Twitter LinkedIn