registration problem

13 years 4 months ago #146578 by mtxrooster
registration problem was created by mtxrooster
I updated a little while ago to cb1.2.3 and discovered today my site is having a problem with the registration system. (I am a previous user of cb, just updated it 1.2.3)..

When a new user clicks on the 'resister' button/icon on the cb_login module, he/she is brought to a registration screen which is comprised of only images. There are two rows of identical images:

Required field | Field visible on your profile | Field not visible on profile | Information: Point mouse to icon
In between the two identical rows is the 'Register' button, also, but there are no fields to enter anything.

Help? Willing to provide anything I can, not sure what ya'll need..

Please Log in to join the conversation.

13 years 4 months ago #146626 by krileon
Replied by krileon on topic Re:registration problem
Would help to know what version you upgraded from. What Joomla release you're using, etc... When fields aren't displaying it typically means a permissions issue. Fields permissions such as Registered, Author, etc... is entirely based off the Tabs permissions that they are on. Check within Tab Management that the tabs your fields are on are set to Public and Published. Also check within Field Management that you've fields set to display on registration. Please also run CB tools to check for any database issues.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

13 years 4 months ago #146749 by mtxrooster
Replied by mtxrooster on topic Re:registration problem
Wasn't sure at the time which version I upgraded from, so I didn't want to throw down misinformation. I'm assuming it was 1.2.1 as that's the only 'old' downloaded file in my local Joomla temp install folder related to the CB project.. I did make progress, however.. While tooling around (and yes, I had run through all the tools in the CB backend prior to posting, hadn't made a difference), I noticed while looking at plugins to see if any of them had updated, that several plugins for CB were grayed out and their names in the far right column had a line through them. Found a plugin's folder in the 1.2.3 zip and resent it, registration now works..

...mostly...

My system doesn't require mod/admin approval. Users get their validation email, click the link, and do get validated. The problem I now face (minor, but annoying nonetheless) is that the confirmation email that is sent to me once they do this isn't coming in correctly. I get the following body for that email message, and was unable to see any place in the registration tab to set what conf. message is sent to the admin to fix it:

A new user has registered at www.mysite.com/Joomla.
This email contains their details

Name -
E-mail -
Username -


Please do not respond to this message as it is automatically generated and is for information purposes only


NOTE: This email was automatically generated from mysite (www.mysite.com/Joomla).

I'm not sure how the pertinent data could be gotten deleted, maybe I'm missing it or something else is wrong, but again, I see a couple areas for editing the delivery messages TO the registering user, but none that go to the admin. If it's a simple matter of editing sql (IE no direct method), just point me in the right direction, I assume the same variables for user messages apply to that as well, but if I'm supposed to be able to see that outgoing admin message in the registration setup, well, I don't, and I guess I'll need help figuring out why mine is missing, heh :) Lemme know what to do..

mtx

Post edited by: mtxrooster, at: 2010/11/22 06:32

Please Log in to join the conversation.

13 years 4 months ago #146767 by krileon
Replied by krileon on topic Re:registration problem
Not quite sure what you've done to your installation. Grayed out plugins are failed installations or incomplete uninstallations. The email should not come through with blank data. This implies the users database in the _comprofiler table is also blank. Please see debug procedures in help us help you from within my signature.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.195 seconds

Facebook Twitter LinkedIn