ImageMagick path wrong since Upgrade to CB 1.7

9 years 1 month ago - 9 years 1 month ago #179071 by mfg-lucker
Hello,this Weekend i´ve upgraded my Site to Joomla 1.7.1 and CB to 1.7
We have now the Problem, that we cannot switch Avatars anymore.
Error Message is


In Admin Settings looks all right.



What can i do ?
I have tried NetPBM, this also doesnt work.
When i look to my Backup from my site, still running in J 1.6.5 and CB 1.4
it still works with the same settings.

mfg-esports.com

Please Log in to join the conversation.

9 years 1 month ago - 9 years 1 month ago #179415 by mfg-lucker
Does noone have a tip for me, how i can find where the problem is ?

Please Log in to join the conversation.

9 years 1 month ago #179462 by beat
Try keeping path to imagemagic empty, so default paths are tried.

/usr/bin is not in your server's allowed paths (openbasedir), and thus imagemagic can't be executed.

You may want to contact your hoster if problem persists with default path.

If all fails, you can always use gd2 instead.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

9 years 1 month ago #180067 by mfg-lucker
Problem solved

My Provider did the following changes in imgToolbox.class.php

Original Code
if($this->_IM_path){
						if(!is_dir($this->_IM_path)){
								$error=1;
								$errorMSG = CBTxt::T('Error: your ImageMagick path is not correct! Please (re)specify it in the Admin-system under "Settings"');
							}
					}

To this
if($this->_IM_path){
						/*if(!is_dir($this->_IM_path)){
								$error=1;
								$errorMSG = CBTxt::T('Error: your ImageMagick path is not correct! Please (re)specify it in the Admin-system under "Settings"');
							}*/
					}

With this Change it works now.
The following user(s) said Thank You: beat

Please Log in to join the conversation.

9 years 1 month ago #180071 by beat
Thanks to you and to your hoster for contributing back analysis of the issue and a fix proposal, highly appreciated.

isdir() is subject to openbasepath restrictions while executables are not.

Fix is to replace is_dir() with is_executable( dir + imagemagic executable file )

Added bug #2920 for fixing in CB 1.7.1 here:
forge.joomlapolis.com/issues/2920

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info

Please Log in to join the conversation.

9 years 3 weeks ago - 9 years 3 weeks ago #181427 by mfg-lucker
Again the same Bug

I discommented the Code again, now it works again.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.414 seconds

Facebook Twitter LinkedIn