update error

1 week 5 days ago #321455 by eriknz
update error was created by eriknz
Since trying to update to CB 2.4.7+2020.11.17.19.46.40.33d80913c I get the error "Duplicate entry '8' for key 'PRIMARY'.
The same when I try CB 2.4.7+build.2020.11.19.14.24.58.59e8c0858.
Did anyone get the same issue?

Please Log in to join the conversation.

1 week 4 days ago #321470 by krileon
Replied by krileon on topic update error
Try running Joomla database fix tool within Extensions > Manage > Database. Next run the database fix tools within CB > Tools. Once done retry. I am not able to reproduce your issue, but that usually happens because something broke the auto increment parameter of a database table and things started inserting into reserved table ids.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: eriknz

Please Log in to join the conversation.

1 week 4 days ago #321477 by eriknz
Replied by eriknz on topic update error
Thank you Kyle,
The problem must be related to the fact that I imported field, tab and user list structure from my old site that still runs CB version 2.4.5 into my new site that ran 2.4.6. The CB tool found many errors in Tab ID's that needed to be changed. I backed up and used the CB repair option and that fixed the problem. I now have successfully upgraded to 2.4.7.

I am still cautious about going with this configuration as I exported and imported between CB 2.4.5 and 2.4.6. My old site has some software issues (unrelated to CB) and I would only try to upgrade CB there if I can find version 2.4.6.

Alternative is to reconstruct the CB structure on the new site manually. I will sleep on it.

Thanks a lot for your powerful advice! I really appreciate that.

Ngā mihi,

Erik.
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.416 seconds