[SOLVED] Groupjive error as Plugin id not found message

2 months 5 days ago - 2 months 5 days ago #331873 by iytworldwide
Hi Team,

PHP Version: 7.3

We are still using old version os Community builder 1.9.1 and it has been working great for us from last 9 years. I was upgrading the joomla from 3.4.6 to 3.6.5 (and later to 3.10) but I am getting a strange error when I try to open Groupjive Groups or Categories after upgrade to 3.6.5. I get an error on screen as

"Plugin id not found"

Can you please guide me as what is the issue here or any hint to troubleshoot or fix this issue will be of great help. To me it looks to be PHP 7.3 related and I may have to customize the plugin to handle it but wanted to check with you first as the error is relatively strange. I highly appreciate your inputs.

Thanks,
Amit

Please Log in to join the conversation.

2 months 5 days ago #331875 by krileon
We do not provide support for out of date products. We also cannot provide product support without an active subscription. Your install is substantially out of date. CB 1.9.1 is not compatible with Joomla 3 and it was released before PHP 7 even existed so it probably doesn't work well on PHP 7 either. Its last supported Joomla version was 2.5. It may install on Joomla 3.x, but you're doing so at your own risk.

I highly suggest resubscribing and updating CB and your addons. Otherwise you need to stop updating Joomla and lock down your install for security purposes. It is not realistic to keep updating the environment around 6 year old code and expecting it to still work smoothly.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 5 days ago #331877 by iytworldwide
Replied by iytworldwide on topic Groupjive error as Plugin id not found message
You are right about old version of code and compatibility issue and I do not expect it to work either. However not every business runs on an ideal environment due to customization. Thanks for your suggestion and I will come to it later next year. 

Please Log in to join the conversation.

2 months 5 days ago #331878 by iytworldwide
Replied by iytworldwide on topic Groupjive error as Plugin id not found message
It was due to the reason that a function 'preg_replace' with /e was used in phpinputfilter library which is deprecated in PHP 7. I replaced with preg_replace_callback and it worked. I will check other similar ones. Next year we will opt for latest CB, groupjive
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.182 seconds

Facebook Twitter LinkedIn