"Field 'status_text' does not have a default value"

5 months 14 hours ago #334375 by webmaster-kcm
No new users can register on our website (joomla4). the error message "Field 'status_text' does not have a default value" appears.
The user is registered in the joomla user administration, but not in the Community Builder.
What is the field 'status_text'? i can't find it anywhere.
regards Karlheinz

Please Log in to join the conversation.

5 months 4 minutes ago #334383 by krileon
"status_text" is a Kunena table column. I've no idea what it's for or why it's erroring though. Do you have Kunena installed? If so try updating it.

Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: webmaster-kcm

Please Log in to join the conversation.

4 months 4 weeks ago #334384 by webmaster-kcm
Replied by webmaster-kcm on topic "Field 'status_text' does not have a default value"
Thank you for the quick answer. I also found out last night (about 3 o'clock :-). The problem was that the field was defined as "not NULL" in the database. I allowed "NULL" and the problem was solved. Then I wrote to Kunena. Today I also got the answer from Kunena recommending this.
Funny detail on the side: the problem was solved by Kunena months ago. With the current version, the bug fix was apparently gone again. That's why the error only occurred when I updated to the new version.
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.183 seconds

Facebook Twitter LinkedIn