Skip to Content Skip to Menu

Registration email link is broken

  • Kampp
  • Kampp
  • OFFLINE
  • Posts: 134
  • Thanks: 10
  • Karma: 12
6 months 2 weeks ago - 6 months 2 weeks ago #335810 by Kampp
Registration email link is broken was created by Kampp
In the email field in "Community Builder -> Configuration -> Registration (tab)" the following code is set:
<a href="[CONFIRM]" target="_blank">Confirm sign-up</a>

The email source code the user receives is the following:
<a href="" target="_blank">Confirm sign-up</a>

As can be seen the link is simply missing from the code. I have confirmed that there is no strange codes in the field that could corrupt the output and also made sure the CB Login module is active (as it is used for many things).

Creator of the CB plugins: "User IP log" and "Public Mail"
Joomla! services/coding: www.toolmaster.dk
Joomla! services/coding: joomla-konsulent.dk
Danish Joomla! hosting: www.joomla-hosting.dk
Last edit: 6 months 2 weeks ago by Kampp.

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68625
  • Thanks: 9109
  • Karma: 1434
6 months 2 weeks ago #335817 by krileon
Replied by krileon on topic Registration email link is broken
[confirm] includes the HTML. If you need strictly just the URL use [confirmlink].


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

  • Kampp
  • Kampp
  • OFFLINE
  • Posts: 134
  • Thanks: 10
  • Karma: 12
6 months 2 weeks ago #335824 by Kampp
Replied by Kampp on topic Registration email link is broken
Did not work.
It inserts a link yes, but the link is domain.com/component/comprofiler/confirm and only leads to a page that says the user needs to log in.

Creator of the CB plugins: "User IP log" and "Public Mail"
Joomla! services/coding: www.toolmaster.dk
Joomla! services/coding: joomla-konsulent.dk
Danish Joomla! hosting: www.joomla-hosting.dk

Please Log in or Create an account to join the conversation.

  • Kampp
  • Kampp
  • OFFLINE
  • Posts: 134
  • Thanks: 10
  • Karma: 12
6 months 2 weeks ago #335826 by Kampp
Replied by Kampp on topic Registration email link is broken
ALSO using just [CONFIRM] does not work either!! I inserts nothing at all, just like if used with <a href="[CONFIRM]" target="_blank">Confirm sign-up</a>  that also did not insert anything.

Creator of the CB plugins: "User IP log" and "Public Mail"
Joomla! services/coding: www.toolmaster.dk
Joomla! services/coding: joomla-konsulent.dk
Danish Joomla! hosting: www.joomla-hosting.dk

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68625
  • Thanks: 9109
  • Karma: 1434
6 months 2 weeks ago #335827 by krileon
Replied by krileon on topic Registration email link is broken
[confirm] includes the HTML. You can't use it inside of href because then you have invalid HTML. Again, use [confirmlink] for inside of HTML as it's the raw URL.

It inserts a link yes, but the link is domain.com/component/comprofiler/confirm and only leads to a page that says the user needs to log in.

You are missing a public and published Joomla menu item to CBs profile page so the URL has no Itemid. This causes goofy things to happen with Joomla's routing. This is why your URL has no SEO otherwise your URL would be domain.com/MENU-ALIAS/confirm.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

  • Kampp
  • Kampp
  • OFFLINE
  • Posts: 134
  • Thanks: 10
  • Karma: 12
6 months 1 week ago #335903 by Kampp
Replied by Kampp on topic Registration email link is broken
If I use just [confirm] then nothing is inserted!

If I use [confirmlink] inside HTML, then a link is inserted, but the link does not include any identifiers. The CBs profile page menu item is public and published. In fact all of the CB menu items are public (this includes the default once in the dedicated CB menu). Clicking the link leads to an error about not haveing permissions to view the page and the user is NOT validated.

Also how would the link work if it is not uniq in anyway? How else would the system know who to activate?

So all in all - nothing works!

Creator of the CB plugins: "User IP log" and "Public Mail"
Joomla! services/coding: www.toolmaster.dk
Joomla! services/coding: joomla-konsulent.dk
Danish Joomla! hosting: www.joomla-hosting.dk

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum

Facebook Twitter LinkedIn