Changing name style configuration

10 years 7 months ago #148787 by tthdoc
Changing name style configuration was created by tthdoc
I originally set up CB with the name style under the configuration manager as single name field. I wanted to change it to first and last name. So I thought I would go to the database and see where the single name was and just copy it to the first name field, and manually separate the name for the last name field. In the database I found the single name was under joom_users and all the entries have a collation of utf8_general_ci. The first and last names are under joom_comprofiler and all have collation's of latin1_swedish_ci (including the ones I added). First, is there an easier way to accomplish what I want? Second, I would like the collations to all be utf8_general_ui, but CB seems to be saving everything with the latin1. Is there a setting to change in CB to tell it what collation method to save the new fields?

Thanks,
Doc

Please Log in to join the conversation.

10 years 7 months ago #148802 by nant
Replied by nant on topic Re:Changing name style configuration
tthdoc wrote:

I originally set up CB with the name style under the configuration manager as single name field. I wanted to change it to first and last name. So I thought I would go to the database and see where the single name was and just copy it to the first name field, and manually separate the name for the last name field. In the database I found the single name was under joom_users and all the entries have a collation of utf8_general_ci. The first and last names are under joom_comprofiler and all have collation's of latin1_swedish_ci (including the ones I added). First, is there an easier way to accomplish what I want? Second, I would like the collations to all be utf8_general_ui, but CB seems to be saving everything with the latin1. Is there a setting to change in CB to tell it what collation method to save the new fields?

Thanks,
Doc


Your database/server is doing this - not CB. Check other installed extensions to verify the collation used there also.

Fix is to manually change the collation to the uft8 one using phpmyadmin.

There is no such setting in CB (and in most other extensions as well) - the issue is a hosting issue imo.

(we had such an issue in earlier JP Hosting service that has been fixed)

Post edited by: nant, at: 2010/12/16 07:40

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.382 seconds

Facebook Twitter LinkedIn