Template not showing in one language

3 months 2 weeks ago #336992 by martynf
Template not showing in one language was created by martynf
Hi,

When we use any part of community builder in the default language we get the correct site template, when we switch language our template does not show, I have checked all assignments and cannot see any reason for this.

Can you help please?

Please Log in to join the conversation.

3 months 1 week ago #337015 by krileon
Replied by krileon on topic Template not showing in one language
CB doesn't handle language switching or template language assignment. We simply render in whatever language Joomla's API says is selected. Given your template doesn't show when switching languages my guess is it's a template assignment issue.

Templates are assigned to menu items not languages. Menu items however are assigned to languages. So ensure you've menu items for each language and have assigned your template to them as needed or that your menu items are set to display for all languages.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 months 1 week ago #337018 by martynf
Replied by martynf on topic Template not showing in one language
Hi Kyle,

Thanks for your answer, however everything is set correctly and it seems that it must be a problem in CB.
I am attaching screen shots of when I look at a user list, when I click on a user, this is the point when we loose the template, this does not replicate in other languages

Thanks

Martyn
Attachments:

Please Log in to join the conversation.

3 months 1 week ago #337019 by krileon
Replied by krileon on topic Template not showing in one language
Clicking a profile link goes to your CB profile menu item. Template assignment is entirely dependent on menu items. For a multi-lingual site you typically have duplicate menu items for each language OR you need to use menu items set to display on all languages. Ensure your template is properly assigned to your profile menu items.

You can check which menu item is being used by turning off Joomla SEO then take a look at the Itemid in the URL. That's actually the ID of the menu item as seen in Joomla's menu manager. That will give you a better idea of what menu item is being used so you can assign your template accordingly.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 months 1 week ago #337020 by martynf
Replied by martynf on topic Template not showing in one language
Hi 
Thanks for this, it is using an item from the Portugese menu and the template is set to the Portuguese one plus in the template item that is also set to that menu as well

Any other ideas?

Please Log in to join the conversation.

3 months 1 week ago #337021 by krileon
Replied by krileon on topic Template not showing in one language
You should have a Joomla menu item to each language for your userlists and your profiles. That's how multi-lingual is setup. You need menu items for every language. Your alternative is to use menu items with language set to All. This isn't really a CB problem, but simply how multi-lingual is handled by Joomla. CB just loads whatever language Joomla tells it is loaded.

As instructed above turn SEO off, navigate to your userlist, and click a profile. That will give you the Itemid in the URL. That is the menu item being loaded. Assign your template to that menu item. Beyond that I don't know what to tell you as CB has no control whatsoever over Joomla template loading behavior, which is entirely Joomla menu assignment based.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.219 seconds

Facebook Twitter LinkedIn