Skip to Content Skip to Menu

Can’t give proper permissions to a user group

  • wilburg
  • wilburg
  • OFFLINE
  • Posts: 24
  • Thanks: 2
  • Karma: 0
3 months 1 week ago #337188 by wilburg
People,

I need users of the user group named “Manager” to be able to send mass emails, and can’t seem to get it done.

This worked out of the box in previous versions of CB. I have given this group “allowed” permissions in all four categories under Community Builder in Global Configuration, and this makes no difference.  What can I do to fix this?

Wilbur

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68625
  • Thanks: 9109
  • Karma: 1434
3 months 1 week ago #337195 by krileon
There isn't a permission specifically for the mass mailer. They just need user management permissions to use it, which are set within CB > User Management > Permissions.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

  • wilburg
  • wilburg
  • OFFLINE
  • Posts: 24
  • Thanks: 2
  • Karma: 0
3 months 1 week ago #337202 by wilburg
Hi, Kyle,

I’ve tried to set permissions in CB - User Management - Permissions.  The thing I am trying to do is set “Access Administration Interface” for two groups (Manager, and Board Members) to “Allowed”.  When I set these permissions and click “Save", the “Select New Setting” drop down  remains persistently at “Allowed, but the “Calculated Setting” field remains as was at “Not Allowed (Locked)”.  I’m attaching a screenshot for “Board Members”.  The screen for Manager (the parent of Board Members is the same.  I want these groups to be able to sent mass emails, and cannot do so.  Is there any help for this situation?

Thanks,


Wilbur
Attachments:

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68625
  • Thanks: 9109
  • Karma: 1434
3 months 1 week ago #337203 by krileon
That usergroup isn't set within Joomla to allow backend access. That permission is just giving backend permissions to CB not for Joomla in general which is why it's showing like that. For them to reach CBs backend management they need access to backend in general. Joomla backend permissions are set within System > Global Configuration > Permissions.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

  • wilburg
  • wilburg
  • OFFLINE
  • Posts: 24
  • Thanks: 2
  • Karma: 0
3 months 1 week ago #337204 by wilburg
I have another site in which the Board Members group and its parent, the Manager group have identical permissions for both the Global Configuration - Permissions, and for the Community Builder - Permissions.  Users of Manager and Board Member groups in old site can access CB - User Management, but mot in the new site.

 

Please Log in or Create an account to join the conversation.

  • wilburg
  • wilburg
  • OFFLINE
  • Posts: 24
  • Thanks: 2
  • Karma: 0
3 months 1 week ago #337205 by wilburg
After screwing with it for a while longer, I was successful in getting members to be able to set mass emails.

Thank you for your patience and your help.

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum

Facebook Twitter LinkedIn