[SOLVED] Fail to add a new Blog

3 years 5 months ago - 3 years 5 months ago #289963 by ml44230
[SOLVED] Fail to add a new Blog was created by ml44230
Hello,
I'm using Community Builder 2.1.0 on Joomla! 3.6.5
I activated the CB blogs plugin and parametered it in order that my members can write blogs from their user profile.
All is working fine when ten the blog model is set to "internal".
However, when I turn the blog model to "Joomla" in the plugin parameters, the field "category" is truncated in the blog form, and the dropdown field is inoperant. O f course, the blog is not created with reason that the category field is mandatory. See attached print screen.
I suspect there is a problem in the form used to create the blog.
Thank you very much for your help
Best regard
Michel
Attachments:

Please Log in to join the conversation.

3 years 5 months ago #289976 by krileon
Replied by krileon on topic Fail to add a new Blog
When it's set to Joomla you need to have Joomla categories available for blogs to be added to. Typically you should select a parent category for it to pull all of its categories from with the "Category" below configuring the "Model" parameter.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 years 5 months ago #290001 by ml44230
Replied by ml44230 on topic Fail to add a new Blog
Many thanks Krileon !
Thank you for your very quick and efficient reply !
I added sub categories "General, Music, Smartphone" to the Joomla "Blog" initial category and it works fine !
Problem solved !
Best regards
Michel
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

3 years 5 months ago #290020 by nant
Replied by nant on topic Fail to add a new Blog

ml44230 wrote: Many thanks Krileon !
Thank you for your very quick and efficient reply !
I added sub categories "General, Music, Smartphone" to the Joomla "Blog" initial category and it works fine !
Problem solved !
Best regards
Michel


I beleive this is covered in the als free CB Primer book.
The following user(s) said Thank You: ml44230

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.520 seconds

Facebook Twitter LinkedIn