[#6680] Language override bug?

3 years 3 months ago - 3 years 3 months ago #294956 by Stentec
[#6680] Language override bug? was created by Stentec
I am not sure if you guys think this is a bug, but it had me scratching my head for a while.

Our website has 3 languages. One of these languages (the default) has an override.php file available, the others have not. If I select one of the languages that do not have an override.php file, Community Builder cannot load that file and then it resets to using the default language, where I thought it would just continue to use the language files of the selected language (but not the overrides).

I solved it by adding an override.php for every language, but my thought is that should not be necessary.

Community Builder version 2.1.2+build.2017.06.13.21.56.00.bfbcdeed3
Joomla 3.7.2
PHP 5.6

Hope this is clear enough.

Please Log in to join the conversation.

3 years 3 months ago #294977 by krileon
Replied by krileon on topic Language override bug?
The overrides are loaded per language and multiple languages do not load at the same time. So if you've Default (English) and Spanish, but you're viewing the site in Spanish the overrides for Default (English) are not going to load. This is normal expected behavior and not a bug.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 years 3 months ago #295042 by Stentec
Replied by Stentec on topic Language override bug?
Krileon,

It's a bit different...

Default is English and the other language is Dutch. If the site language is set to Dutch and there is no override.php for that language, instead of keeping the language Dutch and just not using the override.php file, the site returns to using the Default English language files. So when a user sets the language to Dutch all Community Builder strings stay English.

PS. Is there some release history for Community Builder to find what has changed for the recent updates?

Please Log in to join the conversation.

3 years 3 months ago #295056 by krileon
Replied by krileon on topic Language override bug?
Language fallback behavior shouldn't exist for the override file. That'd likely be a bug then and have added a bug ticket to investigate further.

forge.joomlapolis.com/issues/6680

PS. Is there some release history for Community Builder to find what has changed for the recent updates?

We post a changelog for stable releases otherwise you can monitor progress on our forge below.

forge.joomlapolis.com/projects/cb/issues


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: Stentec

Please Log in to join the conversation.

3 years 3 months ago #295067 by Stentec
Replied by Stentec on topic Language override bug?
Thanks for your answers! The bug is pretty easy to work around once you know what is going on, but it took a while to figure out. :)
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.412 seconds

Facebook Twitter LinkedIn