Mass mailer doesn't work anymore

1 month 4 weeks ago #319743 by asfa
Mass mailer doesn't work anymore was created by asfa
Dear support,
Selecting all the users and using the mass mailer fuction, it doesn't work.
I did some test in simulation mode and everything works properly. When i send without simulation it doesn't work.
With PHP 7.3 version appear a message gateway timeout. With PHP 7.2 the process start but still freeze until appair a message: impossible to send email. Only some users receive the email sent.

The CB version is 2.4.6
PHP 7.2.31-1+0~20200514.41+debian9~1.gbpe2a56b
Joomla! 3.9.20 Stable [ Amani ] 14-July-2020 15:00 GMT

Many thanks for your help.
Luca

Please Log in to join the conversation.

1 month 4 weeks ago #319745 by krileon
Replied by krileon on topic Mass mailer doesn't work anymore
You're trying to email more users than your server can handle at once. Try using the batch feature so you only email a few at a time or select batches of users to email only a few at a time.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: asfa

Please Log in to join the conversation.

1 month 3 weeks ago #319758 by asfa
Replied by asfa on topic Mass mailer doesn't work anymore
Dear Kyle,
I did as you suggest but i also deactivate the joomla Editor. For the moment with 20 address and 30 second it works properly.
I'll do other test with editor acivated and with more emails per time. I'll request to my internet provider more performance.

Many thanks for your support.
Luca

Please Log in to join the conversation.

1 month 3 weeks ago #319766 by krileon
Replied by krileon on topic Mass mailer doesn't work anymore
Shouldn't have anything to do with the WYSIWYG editor, but just that you were trying to email too many at once. The batching will completely eliminate that problem. If you need to regularly email large amounts of users I recommend using a newsletter extension or 3rd party mailer solution like MailChimp to offload the emailing from your web server. Contacting your internet provider won't help with this as they're not responsible for hosting your website and all your web host could do is throw more hardware at it increasing your hosting costs just so you can do larger batches.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: asfa

Please Log in to join the conversation.

1 month 3 weeks ago #319767 by asfa
Replied by asfa on topic Mass mailer doesn't work anymore
Dear kyle,
You are right, thanks for your suggestion.
Leaving the default value (50 email address and 30 second delay) it doesn't work.
I have to send usually to 285 users a email approx 1 time/week. So, also if it takes 7 minutes to do the job with 20 email every 30 second it doesn't matter.

In any case i'll check the solutions you suggest.
Many thanks
Regards
Luca

Please Log in to join the conversation.

1 month 3 weeks ago #319771 by krileon
Replied by krileon on topic Mass mailer doesn't work anymore

I have to send usually to 285 users a email approx 1 time/week. So, also if it takes 7 minutes to do the job with 20 email every 30 second it doesn't matter.

That's too regular to be using mass mailer for that task. A newsletter extension like AcyMailing or external solutions like MailChimp would be able to better handle regular mailings like that. This would also let you better schedule the emails so it doesn't require you to sit there with your browser window open as it goes through the batching.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: asfa

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.421 seconds

Facebook Twitter LinkedIn