[#8141] Userlist search does not respect date range

1 year 4 weeks ago #320157 by KatoKalin
Replied by KatoKalin on topic Userlist search does not respect date range
Here are some news as reply:

1. There have been some database errors which have been fixed (now all green). But it did not help with my issue.
2. The field has always been a date field, never changed. Also the freshly created field has always been a date field.

Now here is something:

Userlist Search Display is set to age => Search set to full age range => No results

Userlist Search Display set to date => Search set to full date range => Correct result shown (1 result)
Also in the latter the query shows that the date field is included.

So it seems that setting fields Userlist Search Display to age, the date fields get excluded from the query.

Please Log in to join the conversation.

1 year 4 weeks ago #320179 by krileon
Replied by krileon on topic Userlist search does not respect date range
Age search works fine on our demo site below.

demo.cbdemosites.com/profiles/userslist/4-members-list

Search between 30 and 35. You should see 2 users founds. Are you sure you're searching an age range that has users? Search URLs below also confirm working.

Exact Age:
demo.cbdemosites.com/profiles/userslist/4-members-list?cb_details_birthday__minval=34&cb_details_birthday__maxval=34

Age Range:
demo.cbdemosites.com/profiles/userslist/4-members-list?cb_details_birthday__minval=30&cb_details_birthday__maxval=35


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

1 year 4 weeks ago #320194 by KatoKalin
Replied by KatoKalin on topic Userlist search does not respect date range
When I do a search on the demo page with default search range 0-100 then all members get shown. But only 4 have an age.
So it looks like it performs a "list all" rather than executing the age range.

Changing the age range to 1-100 shows only 4 members.

I have something similar now:

Created user age 20. Age is correctly shown as 20.
Allowed age range 18-25. So user is perfectly within the allowed rage.
Now go to search. Default value for age search is between 18 and 25.
Perform search, result: 0 user displayed. But it should be 1.
Change search range to 19-25
Perform search, result: 1 member displayed ( the user that has been created above)

So this seems that in this case a "list none" gets performed. I don't know why but maybe it correlates with the searchmode which is 1 in my case and seems to be 0 on the demo page.

Please Log in to join the conversation.

1 year 3 weeks ago #320212 by krileon
Replied by krileon on topic Userlist search does not respect date range
That's working as intended. 0 is no age so it's going to include users with no age. A full range search is treated as no search since there's no other way to clear that search criteria. Only way to workaround this is something like the below to allow a wider range search.

Minimum Year: -100
Maximum Year: -14
Minimum Age: 18
Maximum Age: 100

It has always functioned this way, but it really feels like buggy behavior. It should ideally just have the "No Preference" option to signify no search like other select fields have when searching. Have added a bug ticket for this.

forge.joomlapolis.com/issues/8141


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.176 seconds

Facebook Twitter LinkedIn