Listing page reverts to the standard template when a new list is called up

6 days 2 hours ago #323391 by Ake2017
I assigned the list page to use a non-standard template.
It works fine, until I switch to any other list.
Then it reverts to the standard template.
Switching back to the initial list, it shows the non-standard template, as expected.
But any other list obviously uses the standard template.
A bug? Or did I miss something? Is there a workaround?

Please Log in to join the conversation.

6 days 2 hours ago #323392 by krileon
Joomla template assignment is 100% dependent on the menu item as you assign templates to menu items. Turn SEF off and remove the Itemid in the URL you were sent to. Match that to your menu item. That's what you need to assign your template to. If you want each userlist to have a specific menu item then create menu items for each userlist and assign your template to them.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

6 days 2 hours ago #323394 by Ake2017
As I said, there is no problem assigning another template to the members list page.

Within that page I can select the members sorted and filtered in diverse ways.
It is when I chose any of the other sorts/filters that the template reverts to standard.
My understanding is that I am still on the same members list page though.
Therefore I expect the same template to be used....

Are you now telling me that I need to restrict my members "page" to one sorting/filtering option only.
And then should create new members listing pages for each of the other sorting/filtering options?
(And then assign each of these pages to the non-standard template as well).

Or have I misunderstood something? (It does not seem to be a very practical solution):

Please Log in to join the conversation.

6 days 59 minutes ago #323398 by krileon
The active menu item when searching a userlist should not change. Turn off SEF and retry. Observe what the Itemid is in the URL. This will tell you what menu item it is sending you to when you search.

Are you now telling me that I need to restrict my members "page" to one sorting/filtering option only.
And then should create new members listing pages for each of the other sorting/filtering options?
(And then assign each of these pages to the non-standard template as well).

No, all you need is a menu item per userlist as follows.

Menu Type: Community Builder > Userlist
List ID: USERLIST_ID_HERE
Search Mode: Show List

The alternative is do not have userlist specific menu items and have 1 single userlist menu item with List ID empty then use the dropdown selector to switch between lists. Assign your template to those menu items.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

5 days 23 hours ago #323400 by Ake2017
Thanks for your quick response.
Well, when I select the MembersList menu item I get to ItemID=339 (which displays as expected).
When I, on that page, select any other sorting/filtering that is always ItemID=111 (which displays with the default template)
Q: Shouldn't they all be the same ItemID (=339). I see no reason why the default starting list should be different from the rest.

Anyway, I entered a new menu item for ID=111, in the main menu, and in MenuA, but I am still seeing the default template.
So I must still be doing something wrong.
Any ideas?

Please Log in to join the conversation.

5 days 4 hours ago #323409 by krileon

Anyway, I entered a new menu item for ID=111

The List ID is not 111. You have a menu with an ID of 111 that's what Itemid is. It's the menus id. Find that menu item in Joomlas menu manager. The ID column is on the far right.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.422 seconds

Facebook Twitter LinkedIn