Uploading new members requires a password to be uploaded too

1 month 3 weeks ago #327279 by Ake2017
Uploading new members requires a password to be uploaded too.

Not really a problem, once you know.

But when new members are invited they will be given a username, but an empty PW.

Shouldn't the invitation email set a random password before sending the invitation (when the PW is found to be empty)?

Please Log in to join the conversation.

1 month 3 weeks ago #327298 by krileon
Importing users does not require supplying a password. Remove the password column from your import CSV file and it will auto generate passwords for each imported user.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

1 month 2 weeks ago #327320 by Ake2017
What you describe is what I expect when I don't upload a password.

However this is the e-mail that I receive.
Hello Test Testsson,


You have been added as a User to MySite by an Administrator.

This email has your username and password to log in to www.MySite.com/

Username: Test@mysite.com
Password:


Please do not respond to this message as it is automatically generated and is for information purposes only.
Password is completely empty...
So, what is then wrong.

(When I first tried to submit this post as a Reply or a Quick Reply, I got the 404 error "Call to undefined method CB\Plugin\AutoActions\Table\AutoActionTable::runAction()") several times at around 22.30)

Please Log in to join the conversation.

1 month 2 weeks ago #327342 by krileon
Password is not sent in emails unless generate random password is enabled in CB > Configuration > Registration. It also is only able to be sent in the Pending email. It cannot be sent in the Welcome email except for in specific situations like confirmation enabled, approval enable, AND random password enabled as it will generate a new password after being approved.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

1 month 2 weeks ago #327358 by Ake2017
So, in case a password is not sent in the e-mail, the lines...

Username: Test@mysite.com
Password:


... should be replaced by the lines...

Username: Test@mysite.com
Use the "forgotten password" function to retrieve/reset your password


...or so. Don't you think?

Please Log in to join the conversation.

1 month 2 weeks ago #327376 by krileon
That's up to you. Use language overrides and adjust the email using an IF substitution condition on password if you like. We're not going to implement something like that just to account for specific user import cases. Normally it's best to just turn emails off entirely while performing imports.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.218 seconds

Facebook Twitter LinkedIn