Skip to Content Skip to Menu

Subsitution problem in Mass Mail

1 year 5 months ago - 1 year 4 months ago #332112 by RobWilkinson
[#9095] Subsitution problem in Mass Mail was created by RobWilkinson
I am trying to have the avatar show up as an image in the body of a mass email.

1. Here is what is there in the code prior to sending - : <p><img src="[avatar]" /></p>
2. Here is what CB shows was sent - <p><img src=" domain.org/ [avatar]" /></p>
3. Unsurprisingly this is what arrives - <p><img src=" Domain.org/https://Domain.org/images/comprofiler/919_58337c199203c.png " />

which of course does not work.
Doing the same thing as a link works just fine.

Is JCE making the change or is Community Builder?

I have tried fiddling with the JCE settings but they do not seem to have any effect.

Any ideas appreciated.
Regards,
Rob
Last edit: 1 year 4 months ago by krileon. Reason: Added [#9095] tag to subject

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68637
  • Thanks: 9111
  • Karma: 1434
1 year 5 months ago #332140 by krileon
Replied by krileon on topic Subsitution problem in Mass Mail
[avatar] is outputting as expected (full live path to the avatar image). Something else is prepending domain a second time. Probably JCE doing it during editing is my best guess.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

1 year 5 months ago #332145 by RobWilkinson
Replied by RobWilkinson on topic Subsitution problem in Mass Mail
I suspected as much.

I worked to change the JCE Default profile but that changed nothing. I dont suppose that CB does anything to impact the JCE profile it is launched under?
Regards,
Rob

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68637
  • Thanks: 9111
  • Karma: 1434
1 year 5 months ago #332146 by krileon
Replied by krileon on topic Subsitution problem in Mass Mail
CB isn't even aware JCE exists. JCE probably thinks the URL is a relative URL and is trying to correct relative URLs to absolute URLs. TinyMCE has a setting to adjust this and I assume so does JCE. That's likely the culprit.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

1 year 4 months ago #332161 by RobWilkinson
Replied by RobWilkinson on topic Subsitution problem in Mass Mail
After further observation I do believe the problem lies in CB and not JCE.

If I set the JCE parameter for "relative" in the JCE profile under editor parameters.

JCE returns the URL correctly in the document.as follows:
<p><img src="[avatar]" /></p>
<p><img src="images/images/barnardcastle.jpg" width="606" height="640" alt="barnardcastle" /></p> 

However, when the email arrives,  those source lines look like:
<p><img src=" PickwickClub.org/https://PickwickClub.org/images/comprofiler/919_58337c199203c.png " />


<p><img src=" PickwickClub.org/images/images/barnardcastle.jpg " width="606" height="640" alt="barnardcastle" />



It would apprear that CB adds the Domain in each case. This would be appropriate for the 'Barnard Castle " image in an email and not a
browser based web page. It would appear that the final URL is set after the substitution for [avatar].

Can you see if you get the same by trying to use [avatar] inside an <img/> ?

Regards,
Rob

Can you see if you get the same by trying to use [avatar] inside an <img/> ?
 

Please Log in or Create an account to join the conversation.

1 year 4 months ago - 1 year 4 months ago #332162 by RobWilkinson
Replied by RobWilkinson on topic Subsitution problem in Mass Mail
It llooks like, in the case of <img>,  CB does not distiinguish [avatar] from any other URL and assumes it is relative and therefore adds the domain name to the URL.
Therefore while you can put [avatar] into an email and it will produce a full URL, you cannot use it to embed an <img>. I would say that is a bug.

Regards,
Rob
Last edit: 1 year 4 months ago by RobWilkinson. Reason: Adding further text

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum

Facebook Twitter LinkedIn