[SOLVED] CB Login with CB Connect in a popup

10 years 9 months ago - 10 years 9 months ago #227522 by cbjk
Hello,

My site is gagnereconomiser.com
I'm currently using
- Joomla 2.5.11
- Community Builder 1.9
- CB Connect plugin 4.0.2
- Metropolis template from RocketTheme with their RokBox 2.0.3 extension for popup management

When I use the CB Login module in a normal template position, all is working well.

When I use the CB Login module in a popup window (activated by the "Connexion" button on top of the screen) :
- the normal login is working correctly
- CB buttons are displayed, but they are not working. Nothing happen when they are clicled.
Please, what can I do to make them working there as my goal is to only use the login in the popup position ?

Please Log in to join the conversation.

10 years 9 months ago - 10 years 9 months ago #227545 by krileon
Replied by krileon on topic CB Login with CB Connect in a popup
My guess is whatever you're using for the popup is altering the DOM and all of CB Connects bindings are lost. It uses onClick, not delegate, live, etc.. so if the DOM alters them they won't work anymore without being rebound.

Give me a few minutes and I can push a 4.0.3 that uses live bindings so this won't happen when DOM alters.

forge.joomlapolis.com/issues/4037


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: cbjk

Please Log in to join the conversation.

10 years 9 months ago #227546 by krileon
Replied by krileon on topic CB Login with CB Connect in a popup
Ok, 4.0.3 released that uses live bindings. This shouldn't happen now. Please upgrade and refresh a few times. If issue not fixed then maybe something else (review browser error log when attempting to click a button).


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: cbjk

Please Log in to join the conversation.

10 years 9 months ago - 10 years 9 months ago #227557 by cbjk
Replied by cbjk on topic CB Login with CB Connect in a popup
Thank you very much for this very quick reply.
This is working correctly with the 4.0.3 version.
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.364 seconds

Facebook Twitter LinkedIn