[#4318] Page titles in Groupjive problems

9 years 4 months ago - 9 years 4 months ago #236343 by seajay
We are having an issue with browser page titles in groupjive.

If the group name contains a &, then the page title converts this to &

Is there a way to override this?

Thanks

Please Log in to join the conversation.

9 years 4 months ago #236372 by krileon
Replied by krileon on topic Page titles in Groupjive problems
Check setPathway within cbgroupjive.class.php and remove the htmlspecialchars from setPageTitle usage. This maybe happening due to duplicate htmlspecialchars being applied. Have added a bug ticket to investigate, but can't guarantee when I'll be able to.

forge.joomlapolis.com/issues/4318


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 4 months ago #236471 by seajay
Replied by seajay on topic [#4318] Page titles in Groupjive problems
We have removed on line 2780 and 3816 and now reads setPageTitle( ( $title ) );

Previously, the browser title was showing & but now reads with a single &

So we are getting somewhere....

Any other ideas?
Attachments:

Please Log in to join the conversation.

9 years 4 months ago #236492 by krileon
Replied by krileon on topic [#4318] Page titles in Groupjive problems
There's nothing more I can advise until I investigate the issue, which won't be until after CB 1.10.0 when I am preparing the next GJ release, sorry. You'll need to tinker with the page title functionality until it behaves as expected.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 4 months ago #236613 by seajay
Replied by seajay on topic [#4318] Page titles in Groupjive problems
It's a little disappointing that you can't help, based on the fact that we purchased the software and didn't go for the free version. It's a nasty glitch with the page titles to be honest.

Please Log in to join the conversation.

9 years 4 months ago #236635 by krileon
Replied by krileon on topic [#4318] Page titles in Groupjive problems
The page title has zero impact on functionality. Search engine bots can also translate it properly for indexing so it does not negatively impact page impressions. The issue is just not urgent enough for me to drop development of CB 1.10.0 to fix it, sorry. I'll be investigated and fixed for next GJ release if an issue is found.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.218 seconds

Facebook Twitter LinkedIn