[#5599] Error message with CB conditional in the case of file type required field

8 years 1 month ago - 8 years 1 month ago #276212 by manudeoli
Sorry for my bad english, I hope you will understand me.

I already posted something like this but I have again problems with the CB conditional plugin.

Exemple
  • 1st required field : radio buttons with : are you "parent" or "auxiliaire"
  • 2nd required field conditioned with field conditional self : "Carte vitale" which is an insert file type. The condition is If field "are you" is equal to "auxiliaire" then show
So when I click on register button, it appears an error message like "error - this field is required" (see attachment)


Precision : after this error message, if I retry to select the file (2nd field) there is no error.

My question is : can't we give a condition for a file type required field without an error ?

Thanks for your answers
Attachments:

Please Log in to join the conversation.

8 years 1 month ago #276266 by krileon
Appears to be working fine in my tests. Are you conditioning the field more than once? If you're applying more than 1 condition to the same field those conditions will conflict. A field can only be conditioned once.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

8 years 1 month ago - 8 years 1 month ago #276273 by manudeoli
Yes I have only one condition



I don't understand why ?

CB Conditional 4.0.5
Joomla 3.4.8
Attachments:

Please Log in to join the conversation.

8 years 1 month ago #276302 by krileon
Please PM backend super administrator login credentials and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

8 years 1 month ago #276356 by krileon
Have reviewed your install and it's due to the below known bug.

forge.joomlapolis.com/issues/5599

In short it's due to value resetting. I've disabled resetting within CB Conditional > Parameters for now and confirmed is working fine now. Have added further notes to the bug ticket as have a confirmed repeatable usecase where it breaks.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

8 years 1 month ago #276392 by manudeoli
Oh OK, It's works better ! :cheer:
Thank you

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.814 seconds

Facebook Twitter LinkedIn