Skip to Content Skip to Menu

Search bot problems

  • chanteur94
  • chanteur94
  • OFFLINE
  • Posts: 307
  • Thanks: 13
  • Karma: 1
5 years 7 months ago - 5 years 7 months ago #308028 by chanteur94
Search bot problems was created by chanteur94
Hi

1 - i have this message when I change 'ordering' alphabetical in the Plugin Search-Community Builder

1054 Unknown column 'u.lastname' in 'order clause'

(It works only with 'Name' ordering)

2 - My field search contains firstname and lastname. When I want to search with 2 words with firstname and lastname, the result is 0 résult
(I tried with all the words, and other cases.....) - It seems to work only with one word.

3 - I would like to display the avatar in the Title And Text result . I don't find the syntax. (I tried url, img, background-image .....)

4 - How to change the placeholder ? (Actually in French : Element à rechercher)

Thank you
Last edit: 5 years 7 months ago by chanteur94.

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68617
  • Thanks: 9109
  • Karma: 1434
5 years 7 months ago #308043 by krileon
Replied by krileon on topic Search bot problems

1 - i have this message when I change 'ordering' alphabetical in the Plugin Search-Community Builder

Have added a bug ticket to investigate further.

forge.joomlapolis.com/issues/7314

2 - My field search contains firstname and lastname. When I want to search with 2 words with firstname and lastname, the result is 0 résult
(I tried with all the words, and other cases.....) - It seems to work only with one word.

If you have firstname and lastname it's 2 separate fields. You need to search using "Any words" instead of "All words" under "Search for:".

3 - I would like to display the avatar in the Title And Text result . I don't find the syntax. (I tried url, img, background-image .....)

You won't be able to do this as HTML isn't allowed in Joomlas search results. I'm not aware of a way to force allowing HTML in the search results either, sorry.

4 - How to change the placeholder ? (Actually in French : Element à rechercher)

Placeholder for what? For the search input? CB has no control over that and is probably a parameter of your search module.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

  • chanteur94
  • chanteur94
  • OFFLINE
  • Posts: 307
  • Thanks: 13
  • Karma: 1
5 years 7 months ago #308065 by chanteur94
Replied by chanteur94 on topic Search bot problems
Hi

1 and 4 , Ok

2 - I change to Any Words and here is the result with 2 words (see 2 captures) :
In 1capture , look likes 2nd word not useful (because 3 characters minimum ?)
In 2capture , look likes 2nd word doesn't work
???

3 - Really any chance to have a solution to display AVATAR ? ... I really need this case.

Thank you.
Attachments:

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68617
  • Thanks: 9109
  • Karma: 1434
5 years 7 months ago #308076 by krileon
Replied by krileon on topic Search bot problems

2 - I change to Any Words and here is the result with 2 words (see 2 captures) :
In 1capture , look likes 2nd word not useful (because 3 characters minimum ?)
In 2capture , look likes 2nd word doesn't work
???

The way Joomla search works when using any words is the search is split into words via a space. It then searches the fields for either of those words. If it finds a match then result is displayed. In your case it's checking the firstname and lastname for each of those supplied words. Will review adding the core fields (name, firstname, middlename, lastname, email, etc..) to be always be selectable for searching as what you're needing is probably exact words search against the name field which atm will only be doable if you setup your name usage to use a single name field.

forge.joomlapolis.com/issues/7315

3 - Really any chance to have a solution to display AVATAR ? ... I really need this case.

We've absolutely no control over this. Joomla runs htmlspecialchars on the search result so all HTML output is escaped. We've no means of preventing this. I believe the only way you can have this is to override the com_search default_results tmpl file from your Joomla template as a layout override and remove that htmlspecialchars, but that is likely there for security reasons and suggest maybe posting on the forums about it as there could be some serious risk associated with making that change.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum

Facebook Twitter LinkedIn