Skip to Content Skip to Menu

🏖 Summer has arrived! Start your summer right with our summer sale!Get 30% off Now!

[#7135] Uploaded handy pic will be deformed

6 years 2 months ago - 6 years 2 months ago #304239 by erichburkhard
[#7135] Uploaded handy pic will be deformed was created by erichburkhard
I am using: CB 2.1.4 / CB Gallery: 2.2.0 / Joomla 3.8.7

Before upgrading to CB 2.1.4 & CB Gallery: 2.2.0 the images created and uploaded via IPhone appeared correctly in the Gallery. Then I upgraded to
CB 2.1.4 & CB . Gallery: 2.2.0. Now I have the following behaviour....If I create and upload an image via Smartphone into my Gallery, the image will be deformed as you can see below (red cross).....If I do the same procedure on my PC by selecting and uploading an existing Image file it appears correctly (blue check). Only the fotos of the gallery are affected (when uploaded via Smartphone)....Do you have any idea what to change where?

Attachments:
Last edit: 6 years 2 months ago by krileon. Reason: Added [#7135] tag to subject

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 48072
  • Thanks: 8193
  • Karma: 1437
6 years 2 months ago #304242 by krileon
Replied by krileon on topic Uploaded handy pic will be deformed
Does upload via your smartphone work fine on our demo site below?

demo.cbdemosites.com/

It's possible it's just a styling issue with the thumbnail. Is the fullsize image in the modal window also messed up? Try turning off client side resizing within CB Gallery > Photos > Validation and then re-upload from your smartphone to see if that resolves is. EXIF orientation parsing was implemented in the client side resizing and worked fine in my tests, but it's possible it has some issues in some cases.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

6 years 2 months ago #304270 by erichburkhard
Replied by erichburkhard on topic Uploaded handy pic will be deformed - my tests
Hi Kyle, attached to this email my testing results according to your questions & advises:

1) Upload via smartphone (url: demo.cbdemosites.com/)
I started your demo site on my handy browser and uploaded a pic which I generated first on my smartphone. It works perfect. No deformation at all.

2) Turn ON Client side resizing (in the cb gallery plugin)
If I do this, both image formats - the small image and the full size image as well in the modal window are deformed in the same way.

3) Turn OFF Client side resizing (in the cb gallery plugin)
If I do this, everything works FINE - no deformation at all

So what does this mean? Is there any contradiction concerning the settings in my site and the settings in the demo site?

PS: Here are some other settings in the cb gallery plugin of my website (may be important?)

Always resample = ENBALE
Metadata = DISABLE

Any idea? Regards

Please Log in or Create an account to join the conversation.

  • activha
  • activha
  • OFFLINE
  • Posts: 2283
  • Thanks: 115
  • Karma: 13
6 years 2 months ago - 6 years 2 months ago #304274 by activha
Hello

I have the same problem with these latest updates, all was working fine before.

Have managed to log in with my iPhone on the CB demo website and it's the same thing.
Also have noticed that when trying to upload a new picture from library, the first picture was kept in the upload area and uploaded twice instead of the correct second image

Hope it helps

Will make new tests from the camera instead of library

Thanks
Last edit: 6 years 2 months ago by activha.

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 48072
  • Thanks: 8193
  • Karma: 1437
6 years 2 months ago #304290 by krileon
The deformation appears to be the EXIF orientation behavior in JS. That was recently added since EXIF orientation previously would not work if client side resizing was used. For the time being disable client side resizing to workaround the issue. Looks like this is only failing for portrait images where I only tested landscape so likely a bad if statement in the JS.

forge.joomlapolis.com/issues/7135


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 48072
  • Thanks: 8193
  • Karma: 1437
6 years 2 months ago - 6 years 2 months ago #304291 by krileon
Ok, retested client side resizing with EXIF oriented images as landscape and portrait. Works perfectly fine. I'm not sure what to suggest beyond disable client side resizing. You both appear to be using iPhone. Please try uploading those photos to your cloud, download them onto your computer, then try uploading them. If issue persists please PM a URL to the raw image that I can download and test as all my test EXIF images are working fine.

Please note the latest CB Gallery update was 3 months ago. So it's odd this would suddenly be happening now and suggests a problem with the device. Did your iPhone update recently and then this issue started?

You can find the images I use to test orientation below if you want to give them a try as well.

github.com/ianare/exif-samples/tree/master/jpg/orientation


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
Last edit: 6 years 2 months ago by krileon.

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum