"/media" problems for many people

13 years 7 months ago #31642 by user1
"/media" problems for many people was created by user1
i searched many forums, and it seems many people have got this error

"Upload component - Upload Error
Failed to move uploaded file to /media directory."

I am getting too, while installing

- uddeIM
- CB advanced Search.

my "/media" is 777

could someone give workaround.

Please Log in to join the conversation.

13 years 5 months ago #35813 by bascherz
Replied by bascherz on topic Re:"/media" problems for many people
The problem is most likely the configuration of your PHP server. Many PHP servers are installed by default to allow a single file upload to not exceed 2MB, and some plug-ins are larger than this.

You may be able to control this by adding the following lines to your .htaccess file in the root directory of your domain. Note that the values you enter here may be restricted by the PHP server limits. If you still have problems, contact your host's tech support.

php_value upload_max_filesize 20M
php_value post_max_size 20M

Note that if you increase the maximum file upload size, you may also have to increase the default upload timeout:

php_value max_input_time 120
php_value max_execution_time 120

Post edited by: bascherz, at: 2007/04/18 02:04

______________________
Bruce S - Vienna, VA

Please Log in to join the conversation.

12 years 10 months ago #50616 by nilesh
Replied by nilesh on topic Re:"/media" problems for many people
I have exactly same prob joomla 1.0.13 and cb 1.1 i tried php memory increase solution in htaccess and in php.ini but its not working i can install the plugins using "Install package from web (http/https)" option but
not by browse upload and install option i am using this on local server wamp
Regards
Nik

Please Log in to join the conversation.

12 years 5 months ago #60820 by martiall
Replied by martiall on topic Re:"/media" problems for many people
hi !

sorry for my poor english.

I have the same problem on joomla 1.0.15 with cb1.1. all my local directory are on 777, my php values for upload are on 20M
So i don't understand why this error.

But, you can pass it by uploading you plugin in \components\com_comprofiler\plugin\ directory (unzip files first) and do an install from directory.

I passed the installation of the french language plugin.

Please Log in to join the conversation.

12 years 5 months ago #60916 by lerdab
Replied by lerdab on topic Re:"/media" problems for many people
I have this problem as well. I did some research and it seems some hosts fails to create a directory when the trailing slash is given. I was not able to install anything in the admin, but found a hack for the joomla core installer component. That sovled my issue with all other installs, not CB though. It seems like CB is using it's own installer and maybe it'll need a fix too? The fix I found is here: http://forum.joomla.org/index.php/topic,130060.msg638844.html

Anyone got a suggestion for the CB-installer?

Please Log in to join the conversation.

12 years 5 months ago #60918 by lerdab
Replied by lerdab on topic Re:"/media" problems for many people
Well, it seems I solved it myself when I finally found the plugin-installer functions :)
Just apply the fix from the link in my previous post to [code:1]administrator/components/com_comprofiler/library/cb/cb.installer.php (row 667)[/code:1]
That did the trick for me :)

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.430 seconds

Facebook Twitter LinkedIn