Gd2 library ok / Image Magick not

9 years 11 months ago #140436 by Kolibri
Gd2 library ok / Image Magick not was created by Kolibri
Hi,
CB 1.2.3, Joomla 1.5.20, is auto detecting GD2 library but not Image Magick. could somebody please point me into the right direction?

My php info is provided with attached file.

Direct linking with
/usr/bin/convert (is the provided path on host to Image Magick)
/usr/bin or
/usr/local/bin

does not work.

For testing purposes I installed Joomgallery 1.5.5. This finds Image Magick automatically. But CB does not.

Provider says everything is ok, because Joomgallery 1.5.5 runs and the hint made in
www.joomlapolis.com/component/option,com_joomlaboard/Itemid,85/func,view/catid,112/id,127486/
is already integrated in php info.

Something wrong with CB?

I tested other provider with preinstalled ! CB today. Also no connection to definitely present serverside ImageMagick from cb/configuration/avatar (working in Joomgallery in the preinstalled site)

Any idea?

Thank you!

Attachment cb_01_PHPINFO.zip not found



Post edited by: Kolibri, at: 2010/08/21 21:10

Post edited by: Kolibri, at: 2010/08/23 08:54

Post edited by: Kolibri, at: 2010/08/23 14:18
Attachments:

Please Log in to join the conversation.

9 years 11 months ago #140542 by krileon
Replied by krileon on topic Re:Gd2 library ok / Image Magick not
Does you host have exec() disabled? exec() is required for CBs image library (unless using GD). If is disabled please request your host enable it. Joomgallery is designed for images, it's implementation usage is not comparable to that of CB which is designed for profile/community usage.

Post edited by: krileon, at: 2010/08/24 14:53


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 11 months ago #140556 by Kolibri
Replied by Kolibri on topic Re:Gd2 library ok / Image Magick not
Hello Krileon,
you wrote "If is disabled please request your host disable it." ????? Did you mean enable?

exec() is actually not disabled on my host. I checked another host, also specialised on Joomla environments with installed ImageMagick. exec() was not disabled there too, but CB did not recognize ImageMagick.

The disabled exec() was the clue in

www.joomlapolis.com/component/option,com_joomlaboard/Itemid,85/func,view/catid,112/id,127486/%3Cbr%20/%3E

Must be something else now.

Please Log in to join the conversation.

9 years 11 months ago #140603 by krileon
Replied by krileon on topic Re:Gd2 library ok / Image Magick not

you wrote "If is disabled please request your host disable it." ????? Did you mean enable?

Yes, was a typo; fixed.

exec() is actually not disabled on my host. I checked another host, also specialised on Joomla environments with installed ImageMagick. exec() was not disabled there too, but CB did not recognize ImageMagick.

So you've tried two hosts, both of which ImageMagick is not being detected?

You need to adjust the Path from Auto to the correct path for CB to use convert.exe. Please try the following paths

/usr/bin/
usr/bin/


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

9 years 11 months ago #140638 by Kolibri
Replied by Kolibri on topic Re:Gd2 library ok / Image Magick not
krileon wrote:

you wrote "If is disabled please request your host disable it." ????? Did you mean enable?

Yes, was a typo; fixed.

exec() is actually not disabled on my host. I checked another host, also specialised on Joomla environments with installed ImageMagick. exec() was not disabled there too, but CB did not recognize ImageMagick.

So you've tried two hosts, both of which ImageMagick is not being detected?

You need to adjust the Path from Auto to the correct path for CB to use convert.exe. Please try the following paths

/usr/bin/
usr/bin/


The correct path on my host is
/usr/bin/convert
and has ben tested by technicans of host and myself without success.

Other host (other joomla hosting provider) has been tested with their slightly different path in same way without success too.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.427 seconds

Facebook Twitter LinkedIn