List heading shows site name instead of list name

7 years 4 months ago #190818 by Yxos

Running Joomla 1.7.5 with CB 1.7.1


When creating Lsts under "Lists Management" and then using them in a list to be shown, e.g. via a menu (external URL) using the link provided in the list there is a bug.

The list shows the heading given in the list fine.
It also shows the text from the list allright.

But where it shows the number of members in the list, it uses the name of the site instead of the name of the list.

Example:
  • Site name: "MX5 Club Denmark"
  • List name: "Test List
  • List Description: This is the Test list description


It should say "Test List has 2 registered users" (in english)

When you have several Lists, it looks a bit silly, when they all say "MX5 Club Denmark has x registered users.

Yxos
Attachments:
6 years 7 months ago #214213 by Yxos
Now running Joomla 2.5.7 with CB 1.9.
This error is still not fixed :(

Yxos
3 years 8 months ago #271118 by Yxos
Now running Joomla 3.0.4 with CB 2.0.11.
This error is still not fixed :(

Yxos
3 years 8 months ago #271132 by nant

Yxos wrote: Now running Joomla 3.0.4 with CB 2.0.11.
This error is still not fixed :(


Working as designed.

Each user list is basically designed to list users of a specific site.
So this is why the site name is included in the number of users message.

Your "potential bug" is basically a potential new feature.
3 years 8 months ago - 3 years 8 months ago #271138 by Yxos
I can see I might have xplained myself pooly, because the main point was not included in my original description of this problem.

Each list has the option to select exactly what UserGroups to include in the list. It works like a filter.

This is a good feature, because you may make a list to show all users.
You may make another list to show moderators, and another list to show Board Members.
Each list only have to point to the right UserGroup.

Furthermore; the list shows the number of users contained in the UserGroup in Question.
In my example, I have selected a UserGroup containing only 2 users. (We have more than 500 users)

In that case in makes sense to write "<ListName> contain 2 members" rather than "<SiteName> contains 2 members" because this is not true.

I have another list refering to the Board members. There are 4 of them.
When showing that list, the text shown is exacly the same as for the other list, only with the number 4 in it; "<SiteName> contains 4 members"

When CB developers have choosen to show the number of users INCLUDED IN THE FILTER FOR THE LIST it also makes sence to write the name of the list instead of the sitename, I think.

You might want to see these examples form our site. They are inDanish, but I think they are self explanatory anyway:

The Board, 4 members: mx5club.dk/kontakt/2011-09-30-09-23-34/userslist/5-bestyrelsen
Webmasters, 2 members: mx5club.dk/kontakt/2013-06-11-07-08-56/userslist/14-webmaster

I hope I have explained myself better this time.

Yxos
3 years 8 months ago #271144 by nant
I understood the use case and I personally agree with this feature.

Just stating that the current implementation is working as designed - so it is not a bug.

This would be a new feature request - to basically have list user message personalized for each user list.

I have opened a new feature request here for future consideration:

forge.joomlapolis.com/issues/5532
Moderators: beatnantkrileon
Time to create page: 0.454 seconds
Facebook Twitter Google LinkedIn