[SOLVED] CB paid subscriptions failed

4 months 1 week ago - 4 months 6 days ago #327804 by ASconbs
[SOLVED] CB paid subscriptions failed was created by ASconbs
Hello there
Installation of CB paid subscritions failed for me. I get this error:

System Information
Joomla: 4.0.5
PHP: 8.0.14
Database: mysql 10.3.32-MariaDB

Package
File: 000_cbplug_CBSubs_MAIN-4.5.3+build.2022.01.05.17.44.28.2d4319090.zip
Log:
42000, 1118, Row size too large (> 8126). Changing some columns to TEXT or BLOB may help. In current row format, BLOB prefix of 0 bytes is stored inline.

Any suggestions what to do?
/ASconbs

Please Log in to join the conversation.

4 months 1 week ago #327814 by krileon
Replied by krileon on topic CB paid subscriptions failed
Please search before posting as this has been answered quite a lot already.

www.joomlapolis.com/forum/search?query=Row%20size%20too%20large%20(%3E%208126)&childforums=1

It's a database configuration problem. Usually due to collation being set incorrectly as explained below.

www.joomlapolis.com/forum/255-developer-members-support/244256-solved-1146-table-l-t-jooml-josgt-cbsubs-payments-doesn-t-exist#326156

It can also be due to incorrectly configured Innodb as explained below, but since you're on a relatively newer version of Mariadb it's probably just a collation problem.

www.joomlapolis.com/forum/153-professional-member-support/242484-installation-cb-connect-failed?start=12#318734


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

4 months 6 days ago #327855 by ASconbs
Replied by ASconbs on topic CB paid subscriptions failed
Thank you for your quick answer, and links to similar cases.
Just want to provide my feed back here:

I changed the Collation for for serverconnection to: utf8mb4_general_ci
...and I changed the collation for all tables to: utf8mb4_general_ci
I did not mark the tickbox for all table columns
This solved my problem
Thank youASconbs

Attachments:
The following user(s) said Thank You: beat, krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.235 seconds

Facebook Twitter LinkedIn