Wrong datatype error in cb.core.php

14 years 11 months ago #26937 by rspurlock
Wrong datatype error in cb.core.php was created by rspurlock
Hello all,

We're upgrading a customer CB site to 1.0.2 from 1.0.1. The upgrade (non-expert) went fine but when we users cannot log into the Login page and any new users aren't and cannot be confirmed. When editing a users, I get the error:

Warning: in_array(): Wrong datatype for second argument in /var/www/vhosts/airgator.com/httpdocs/dev/components/com_comprofiler/plugin/user/plug_cbcore/cb.core.php on line 239

It comes up several times and let me add a user or edit a user but they still cannot log in nor will they be confirmed. I have seen several posts about this error and I would assume someone would have a fix but no one's responding to those users or offering any advice.

Do I need to update the CB core plugin? If so, where do I find an updated version to install? Any other plugins this should apply to as well?

Here's the system info:
Mambo 4.6.1
PHP 4.4.2
Mysql 4.1.21
CB 1.0.2

Anyone?

TIA,

Rob

Please Log in to join the conversation.

14 years 10 months ago #28889 by todd12
Replied by todd12 on topic Re:Wrong datatype error in cb.core.php
I've got the same problem does anyone have any answers?

Please Log in to join the conversation.

14 years 10 months ago #29471 by cajebo
Replied by cajebo on topic Re:Wrong datatype error in cb.core.php
i too am now experiencing the same errors.

maybe three posts to this thread will be the charm?

error as stated when trying to edit a user:

[code:1]Warning: in_array() [function.in-array]: Wrong datatype for second argument in .../public_html/components/com_comprofiler/plugin/user/plug_cbcore/cb.core.php on line 239
[/code:1]

Mambo Install Info:

Mambo Version: Mambo 4.6.1 Stable [ Helix ] 5-Oct-2006 03:00 GMT


michael

Post edited by: cajebo, at: 2007/01/21 00:26

Please Log in to join the conversation.

14 years 9 months ago #31497 by nikdooley
Replied by nikdooley on topic Re:Wrong datatype error in cb.core.php
I am having the same issue - is there anyone that can help us.

Thank you in advance

Please Log in to join the conversation.

14 years 9 months ago #31512 by nant
Replied by nant on topic Re:Wrong datatype error in cb.core.php
please run the database check in the cb tools section of cb 1.0.2 and see if it returns all green.

Please Log in to join the conversation.

14 years 9 months ago #31515 by nikdooley
Replied by nikdooley on topic Re:Wrong datatype error in cb.core.php
The checks came back all green with the Check Community Builder Database. I am still getting the Warning: in_array() [function.in-array]: Wrong datatype for second argument in .../components/com_comprofiler/plugin/user/plug_cbcore/cb.core.php on line 239 within the user managament area.

Also I cannot login on frontend under any of the users. I was able to before, (even with the warning of wrong datatype) but now all of a sudden i get:

"You are not authorized to view this resource.
You need to login. " and it shows the login form. (I have only the cblogin enabled)

I am running Mambo 4.6.1 & CB 1.0.2.

Not sure if the front end login is related to the warning of wrong datatype but I thought this might be another symptom of the same issue.

Would appreciate help ASAP as we would like to relauch our site with it working!

Post edited by: nikdooley, at: 2007/02/19 08:32

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.229 seconds

Facebook Twitter LinkedIn