Community Builder 2.0 beta 5 released !

8 years 8 months ago #246742 by martinmg

If possible is your host able to upgrade you to PHP 5.4? If they can then please upgrade and see if issue persists.


My host cannot provide different PHP-versions to customers so unfortunately not. It would be a huge project just for this test.

Please Log in to join the conversation.

8 years 8 months ago #246743 by krileon

My host cannot provide different PHP-versions to customers so unfortunately not. It would be a huge project just for this test.

We've confirmed it appears to be PHP related. We've tested PHP 5.3, which has the issue. Then PHP 5.4, which does not. We'll be looking into a way to resolve the issue, but at this time I unfortunately have nothing to suggest as a workaround.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: martinmg

Please Log in to join the conversation.

8 years 8 months ago #246749 by Madan
Replied by Madan on topic Community Builder 2.0 beta 5 released !
Hi guys!

A couple of days ago I installed beta 4 without problems, except from a couple of plugins that didn't work (but that was known right?).

Today I did an upgrade to beta 5. Install was smooth but now existing profile pages don't show. All I get is a blank page.

I'm using PHP 5.3.27. Might that be the problem?

Keep up the good work :cheer:

Please Log in to join the conversation.

8 years 8 months ago #246751 by beat

martinmg wrote: Hi,
...

When I try to access a profile list (e.g. index.php?option=com_comprofiler&task=userslist&Itemid=297)

I get the following error Fatal error: Cannot access static:: when no class scope is active in /../../public_html/test/j30/libraries/CBLib/CBLib/Language/Pluralization.php on line 53


Thanks for the precise feedback.

Ok, that's a PHP 5.3-related issue. Easy fix for that one is to replace the keyword "static::" by "Pluralization::" on that line. Is fixed for next release.

Beat - Community Builder Team Member

Before posting on forums: Read FAQ thoroughly -- Help us spend more time coding by helping others in this forum, many thanks :)
CB links: Our membership - CBSubs - Templates - Hosting - Forge - Send me a Private Message (PM) only for private/confidential info
The following user(s) said Thank You: pepperstreet

Please Log in to join the conversation.

8 years 8 months ago #246753 by pepperstreet

krileon wrote: You can use "Custom HTML" fields for that purpose.


Yep, i know. But the "tabs titles" are available in the code. They are just not used in this layout style. Why not output them... then there is no need to create extra fields etc. Redundancy IMHO.

krileon wrote: We're not adding anymore layouts. Those provided were already there and we've just made it an option to use either/or. We've plans for a layout builder and XML usage on frontend so we don't want to implement then have to remove. A lot of your suggestions can be done with CB Auto Actions adding jQuery to the page if you're wanting them now.


o.k. I just noticed the updated and extended layout styles for "CB Tabs". Just thought this would make sense for complete configuration options... and because it is a very similar parameter. Just a different context.

Please Log in to join the conversation.

8 years 8 months ago #246754 by martinmg

Ok, that's a PHP 5.3-related issue. Easy fix for that one is to replace the keyword "static::" by "Pluralization::" on that line. Is fixed for next release.


Thank's. It works :-)

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.384 seconds

Facebook Twitter LinkedIn