[SOLVED] "The email domain is not allowed" in PHP 8.0, but works in 7.4

2 months 2 weeks ago - 2 months 2 weeks ago #333206 by dhphllps
This is on a site that I just updated from J! 3.10 to 4.2.8, PHP 8.0.27. Changing PHP back to 7.4 fixes the problem.

New users are not able to register, and the forgot login and profile edit functions are not working. In each case, entering valid information and submitting the forms results in the error message "The email domain is not allowed." Is that a CB message or a Joomla message?

Email server settings are correct. There is no email validation set in CB email field parameters. CB Anti-spam plugin is not installed.

Where to look for solution for PHP 8?

Please Log in to join the conversation.

2 months 2 weeks ago #333215 by krileon
There is no "The email domain is not allowed" check in CB or Joomla. That sounds like custom validation you added to the email field. Edit your email field in CB > Field Management and check its validation settings carefully.

Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 months 2 weeks ago #333216 by dhphllps
Found it! It's a new setting option in Admin Tools WAF to selectively allow or block email domains. Apparently the default is to Block *. Toggling that to Allow fixed it.
The following user(s) said Thank You: krileon

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.184 seconds

Facebook Twitter LinkedIn