[SOLVED] CB Invites - Unknown column 'b.username' in 'where clause'

3 years 2 months ago - 3 years 2 months ago #314348 by jakeatencio
I updated to the latest version of cb invites and did a quick test and it worked fine. I then deleted the test invitation that I sent using the drop down option in the invite list for my account. I then tried to invite someone for real and it would not work. I don't see the captcha and when I go to look at the plugin I get the following error:

Unknown column 'b.username' in 'where clause'

I also updated the cbantispam, cbcorefieldsajax, cbautoactions, cbfooter plugins
I added but haven't published or started using cbconditional, cbautowelcome

Please Log in to join the conversation.

3 years 2 months ago #314361 by krileon

I don't see the captcha

Captcha is not visible to CB Moderators and it requires CB AntiSpam to be installed, published, then ensure its captcha has been configured to your liking otherwise defaults should work fine out of the box. Next you need to be sure you've enabled captcha within CB Invites > Parameters > Invites.

when I go to look at the plugin I get the following error:

Unpublish CB Invites and see if that error goes away. I don't see how that could possibly be happening. The username column is only included in the query if a search is being made, which will also cause the necessary table to join. All of which is working fine in my tests.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

3 years 2 months ago #314369 by jakeatencio
Not sure why, but the unknown column error went away and doesn't seem to be returning. I reinstalled the plugins and CB last night, but it didn't seem to fix. Today its ok.
Reconfigured the site plugins to use Captcha Recaptcha v3. Works in most respects, but I'm closing this posting to start another one with a different subject. Thanks for your help.

Please Log in to join the conversation.

2 years 7 months ago - 2 years 7 months ago #318140 by kdave321
I just caught this same error. I was looking at the current invites in the backend - resending some and worked several times.
Then I tried to search on a string in the invites, and saw that error message.
I have logged off and back on and the error remains now just clicking on the "Invites" button.

Please Log in to join the conversation.

2 years 7 months ago #318158 by krileon
Ah, I see the issue. This happens when performing a search on the invites in backend. Am creating a bug ticket to fix.

forge.joomlapolis.com/issues/7966


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: kdave321

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.226 seconds

Facebook Twitter LinkedIn