Skip to Content Skip to Menu

Blog Link - Redirecting to Site Home Page

  • drhustle
  • drhustle
  • OFFLINE
  • Posts: 41
  • Thanks: 11
  • Karma: 0
1 month 3 weeks ago #337695 by drhustle
Greetings, I have been testing out the features on the CB Profile and have set up the option for users to create blog posts. At this time, users are able to click the blog menu item and input the text in order to create the blog, however, once the blog is created any attempt to click the blog title (which is a link) redirects to the site home page.The part that stumped me when trying to trouble shoot is that the blog link address is in the site address bar, but the home page is what shows up on screen. I have included an image showing the blog title and link address at the bottom in the status barI have included an image showing the blog link in the address bar with the site homepage showing on screen.Any assistance or direction on how to get the blogs to become visible to viewers when the blog title is clicked would be greatly appreciated. If there is any additional information or context needed to assist with this, please let me know.Thank you 
Attachments:

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68625
  • Thanks: 9109
  • Karma: 1434
1 month 3 weeks ago #337706 by krileon
Replied by krileon on topic Blog Link - Redirecting to Site Home Page
You're missing a public and published Joomla menu item to CBs profile page so the link has no Itemid and thus no menu assignment resulting in home page menu item being applied. So you either need to be sure you've a public and published Joomla menu item to CBs profile page or you need to create a Joomla menu item of menu type Community Builder > Plugin then for Plugin select CB Blogs.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

  • drhustle
  • drhustle
  • OFFLINE
  • Posts: 41
  • Thanks: 11
  • Karma: 0
1 month 3 weeks ago #337710 by drhustle
Replied by drhustle on topic Blog Link - Redirecting to Site Home Page
I appreciate the quick response, there is a published Joomla menu item to CBs profile page that was set to registered so that only registered site members can view profiles, however I have changed it to public for testing purposes based on your feedback.

I also create a Joomla menu item of menu type Community Builder > Plugin then for Plugin select CB Blogs that is published to the user/profile menu. 

Once these two changes were made, clicking the Blog Title still redirects to the home page. The only change is that the CB Blog (plugin) menu item on the profile menu will direct to the blog ONLY if a specific blog ID is entered in the menu item details. If the ID is left blank , there is a "not authorized" error that appears. When trying to click the blog title of a different user, that also will only direct to the home page.

I have included an image of the menu item changes that I made to check if my changes match the direction given .

Thank You
Attachments:

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68625
  • Thanks: 9109
  • Karma: 1434
1 month 3 weeks ago #337711 by krileon
Replied by krileon on topic Blog Link - Redirecting to Site Home Page
The public and published profile menu item should be all that you need (this is mandatory for CB to avoid problems like this). The blog links will then use it for its menu item and subsequently Joomla module menu assignment.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

  • drhustle
  • drhustle
  • OFFLINE
  • Posts: 41
  • Thanks: 11
  • Karma: 0
1 month 2 weeks ago #337729 by drhustle
Replied by drhustle on topic Blog Link - Redirecting to Site Home Page
Thank you again for the reply regarding the blog link, after additional troubleshooting I have discovered that it seems to be template related. With the default joomla templates and others I have used in the past, the blog display functions as expected. However, with this new template that I have been trying the problem persists. 

I will reach out to the template designers for further assistance or look for an alternative template to adopt.

Take Care
The following user(s) said Thank You: krileon

Please Log in or Create an account to join the conversation.

  • drhustle
  • drhustle
  • OFFLINE
  • Posts: 41
  • Thanks: 11
  • Karma: 0
1 month 2 weeks ago #337778 by drhustle
Replied by drhustle on topic Blog Link - Redirecting to Site Home Page
After spending the last few days trying to trouble shoot this issue, going back and forth with the template developer and testing out several more templates from different developers and also the cassiopeia joomla default, I have been able to get the blog title link to display the blog content but in ALL instances it will still redirect to the home page.

What I have tried
- I used several other templates and each time assigned it (Template 1) only to the "home" menu item of the site. All other pages, including the user profile are set to (Template 2).

When the blog title is clicked from the profile page it redirects to the home page always (template 1) and displays the blog content under whatever is on that page.  I have a photo gallery on the home page that is only assigned to the "home" menu item and I don't want it to show above all of the blogs.

I have even disabled the image gallery module but the blog still goes to the home page for display.It appears that something about the blog title link wants to call the home page as the place to display the content and it is not unique to one template, it happens with all of them.

Lastly, I created a CB Blogs item for the user menu, with a blog ID assigned it displays as expected but for the owner only, other users can't access the owners user menu. If no Blog ID is assigned an error message results.

Questions I couldn't figure out1. Is there a way to tell the blog which site template to display on? - The plugin template option is only "default", but that isn't one of the site templates.2. Is the blog display supposed to show on the site home page? Because if it is, then is there a way to direct it to a not do that?

IMAGES INCLUDED
- Blog display error on the desired template (when blog title clicked below canvas image)
- Blog display error on Cassiopeia template (when blog title clicked below canvas image)
- User menu item error (no Blog ID assigned)
- User menu item correct display (Blog ID assigned) *Note - Even though this works, it only works for the profile owner, not others.

I really wanted to try and figure this out and have spent the last few days trying to figure it out with the template developer, but when it was discovered the issue was reproduced on all templates, they suggested I follow up with you. I am at a loss and don't know if it's a quick fix that i'm just missing, but I feel clueless.

This isn't really an urgent fix, but it is something I would like to solve to avoid confusion as I anticipate more users accessing and using it in the next few months.

Thanks
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum

Facebook Twitter LinkedIn