Auto Welcome Not Sending

2 years 2 months ago #313747 by tmir
Replied by tmir on topic Auto Welcome Not Sending
Yes they are only registering through CB and I’m only using the CB PM system. I don’t know what’s going on.

Please Log in to join the conversation.

2 years 2 months ago #313749 by krileon
Replied by krileon on topic Auto Welcome Not Sending
Please PM (see my signature for link) backend super administrator login credentials and will take a look.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

2 years 2 months ago #313751 by tmir
Replied by tmir on topic Auto Welcome Not Sending
PM sent

Please Log in to join the conversation.

2 years 2 months ago #313766 by krileon
Replied by krileon on topic Auto Welcome Not Sending
CB was out of date. You had latest stable, but we've had several build releases since then and have updated your install for you.

As for what's causing your issue. You've a Redirect and Auto Login auto action on the onAfterUserRegistration trigger. That trigger fires before activateUser function can activate the user. In the activateUser function is a trigger that CB Auto Welcome acts on. This means you're redirecting before CB Auto Welcome has a chance to do anything. I've corrected the trigger for both to onAfterSaveUserRegistration which is fired after the entire registration process is fully complete. The redirect action was also redundant so has been unpublished. I've confirmed CB Auto Welcome works fine now.

Please also note you've several tabs incorrectly setup for the canvas layout. When placing tabs in "Canvas Main Middle" tab position their display mode needs to be "Tab Menu" or "Nested Tab Menu" or they won't display correctly or at all. I've corrected all the incorrectly configured tabs for you. If you do not want to use the tab menu display mode you will need to use a different tab position as that position is not designed for any other display mode.

In addition to the above the usergroups assigned to your admin user do not appear correct. No one should be assigned the Public usergroup directly. Your user typically should only ever have the Super Users usergroup for global permissions to access everything. So you may want to also correct that or you could now or in the future have permission problems.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.
The following user(s) said Thank You: nant

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.195 seconds

Facebook Twitter LinkedIn