Avatar upload not working

13 years 6 months ago #82739 by uberweiss
Avatar upload not working was created by uberweiss
Im having a minor problem here. My users can't upload their own avatars to their profiles eventhough the files are within the size and dimension which is allowed.

It works fine if they are chosing from the image gallery

The Image settings is.

path to imagemagick - auto
path to netpbm - auto
image software - GD2 library
Image - Yes
allow upload - yes
Always resample avatar uploads - Yes
Use Image gallery - Yes

Imagemagick - not installed
netPBM - not installed
GD1 library - Not installed

Please Log in to join the conversation.

13 years 6 months ago #82741 by nant
Replied by nant on topic Re:Avatar upload not working
uberweiss wrote:

Im having a minor problem here. My users can't upload their own avatars to their profiles eventhough the files are within the size and dimension which is allowed.

It works fine if they are chosing from the image gallery

The Image settings is.

path to imagemagick - auto
path to netpbm - auto
image software - GD2 library
Image - Yes
allow upload - yes
Always resample avatar uploads - Yes
Use Image gallery - Yes

Imagemagick - not installed
netPBM - not installed
GD1 library - Not installed


Joomla version?
CB Version?
PHP version?
What do you mean by users cannot upload?
Error messages?
Error log message?
Does debug on give extra clues?

Please Log in to join the conversation.

13 years 6 months ago #82745 by uberweiss
Replied by uberweiss on topic Re:Avatar upload not working
Im running joomla 1.5.8
CB 1,2 RC4
PHP 5.2.8 i think

It starts to load and when it is done the profile is just shown with the default avatar pic.


:blush: how do i run debug?

Please Log in to join the conversation.

13 years 6 months ago #82746 by nant
Replied by nant on topic Re:Avatar upload not working
uberweiss wrote:

It starts to load and when it is done the profile is just shown with the default avatar pic.


Sorry, I don't understand what this means.

Are you able to upload an image from the edit profile option?

If not, exactly what message do you see?

Please Log in to join the conversation.

13 years 6 months ago #82747 by uberweiss
Replied by uberweiss on topic Re:Avatar upload not working
I dont get any messages other than my changes have been saved.

Please Log in to join the conversation.

13 years 6 months ago #83900 by cvoogt
Replied by cvoogt on topic Re:Avatar upload not working
I am also experiencing this, and it is a new phenomenon. I have not changed anything on my site recently, but somehow this is now happening.

I am using Joomla 1.5.8 and CB 1.2 RC3.

If the user goes to Edit Profile and changes their profile image there, they are able to choose an avatar icon or remove their image, but if they try to upload their own image, they get this message:

"Please select a file before uploading"

Nothing gets uploaded apparently.

If they instead use the Update Your Image link in the CB menu, they try to upload an image and it then just shows them the Update Your Image page again, with no other notices, and no changes to their profile image. I turned on maximum PHP error reporting but there were no PHP errors.

I have just upgraded CB to 1.2 RC4, and the problem remains the same.

I have checked all my directories and all report back as writable. This *was* working fine until recently. The only setting that has changed on my Joomla installation in the past few months is that I turned the Cache off and back on once.

I have checked the images/comprofiler permissions. They were set to 777, but I set them to 755 and they are still writable, but this did not help. Same goes for my temp directory.

My PHP.ini is set correctly ... upload_max_filesize is 24 M, and file_uploads are set to On.
upload_tmp_dir is not set - should it be?

I have tried it with both GD2 and NetPBM, both of which are supported by my server and detected by CB.

I'm out of ideas. Anyone have any suggestions?

Post edited by: cvoogt, at: 2009/01/02 17:09
The following user(s) said Thank You: trueseo

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.192 seconds

Facebook Twitter LinkedIn