How to integrate Fireboard with CB?

12 years 4 months ago #39937 by judd_muir
Joomla v1.5
I installed CB 1.0.2
Then I installed Fireboard 1.0.1

I can't see anything in my CB installation relating to forums!

I think it would be really useful to have a "How to integrate Fireboard with CB" thread that goes into sufficient detail (and based on a new, clean site)

Here's the first lines:
1. Install the Fireboard component
Extensions->Install/Uninstall->Install from URL:
joomlacode.org/gf/download/frsrelease/4719/11072/component_Fireboard_Forum_1.0.1.beta.zip

2. Go to the Fireboard component and install the database:
Components->Fireboard->Click on "Clean install"

If, when you go to the "Forum administration tab", you get an SQL error, see this post:
www.bestofjoomla.com/component/option,com_fireboard/Itemid,38/func,view/catid,65/id,12610/#12610

3. Integrate with CB like so:
(someone please complete!)

Post edited by: judd_muir, at: 2007/06/22 23:07
12 years 4 months ago #39938 by judd_muir
3. Integrate with CB like so:
Fireboard->Configuration->Avatar Integration: Set to "CB"
Fireboard->Configuration->Profile Settings: Set to "CB"
Fireboard->Configuration->Community Builder->Community Builder user profiles: Set to "Yes"
Fireboard->Configuration->Community Builder->Create Community Builder forum profile: Click!

4. Hmm, still no Fireboard...
12 years 4 months ago #39957 by judd_muir
A little help here would really be appreciated! After doing the steps as I've indicated, on two different sites, I'm still without a Fireboard forum showing up anywhere (not in front-end or back-end).

In Components->CB->Field Management and Components->CB->Tab Management, there are some new items such as " _UE_FB_TABTITLE", which are showing as published.

In theory I've done everything right, unless I've missed something major. Help please!
12 years 4 months ago #39959 by judd_muir
Okay, got it - seems to be a little secret, in that nowhere in the Fireboard configuration relating to CB do they mention that you need the Fireboard for CB plugin!

It's available here:
www.bestofjoomla.com/component/option,com_sobi2/sobi2Task,sobi2Details/catid,5/sobi2Id,70/Itemid,41/

So:
4. Install the Fireboard for CB plugin.
Components->Fireboard->Plugin Management->Install New Plugin
Components->Fireboard->Plugin Management-> CB Fireboard Plugin : Publish
Components->Fireboard->Tab Management->Forum : Publish (NB: make sure you publish the Fireboard one, not the SimpleBoard one!)

At this point, CB craps out for me with "Zip library missing", so I can't install the plugin! Maybe you'll have more luck - me, I'm off to fix the zip issue. Sigh. I hope all this is not in vain, and someone else benefits from this post!

Ok, zip file error corrected as per this post:
www.joomlapolis.com/component/option,com_joomlaboard/Itemid,/func,view/catid,28/id,36943/#36943

Plugin uploaded and published. Tab published.

Still no effing forum tab showing up! I can't believe everyone else has done this so easily, I feel like I'm banging my head on a brick wall....

Post edited by: judd_muir, at: 2007/06/22 22:56

Post edited by: judd_muir, at: 2007/06/22 23:01
12 years 4 months ago #39979 by judd_muir
In tab management, "forum" wasn't showing up because of the "position" I had chosen. Don't know why that should be, but choosing "tab main" resulted in it being shown, hoorah!

However, there appear to be no "users" in the fireboards users list, despite in theory being connected to CB. Yet another stumbling block, sigh.

Post edited by: judd_muir, at: 2007/06/24 17:43
12 years 4 months ago #40019 by judd_muir
5. Add a menu item
Menu->Menu Manager : Select the menu in which you want the "forum" link to appear.
then New->Select Menu Item Type->Fireboard

Hoorah!
Moderators: beatnantkrileon
Time to create page: 0.450 seconds
Facebook Twitter Google LinkedIn