HUGE ISSUE: Account & Subscription NOT Activated!

12 years 4 months ago #105273 by carlosleon0615
Replied by carlosleon0615 on topic Re:HUGE ISSUE: Account & Subscription NOT Activated!
I'm sorry I don't think I understand what you mean with "It's advised not to revert to an older version" and with "replace all the files in the same manor you upgraded to 1.0.2.".

I followed Beat's installation instructions on this post:
CBSubs 1.0.2 Released!

Should I do exactly the same as above (but using 1.0.1)? This means NOT uninstalling most plugins but simply reinstalling version 1.0.1 on top.

I'm also using JoomlaPack and I was thinking of reverting to a backup I made before upgrading to 1.0.2 using JoomlaPack's restoration method.
Is this what is Not recommended?

Please Log in to join the conversation.

12 years 4 months ago #105274 by krileon
That is one method. You could simply unpack the plugins and copy the files over on top of yours and it will downgrade them.

You can also revert to a backup of your site.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 4 months ago #105329 by carlosleon0615
Replied by carlosleon0615 on topic Re:HUGE ISSUE: Account & Subscription NOT Activated!
I confirm this IS A PROBLEM in CBSubs 1.0.2.

This is what I've done to confirm it:
1. a) I uninstalled CBSubs 1.0.2 including all plugins and module.I wanted to make sure I had a clean install. I made sure all files were completely gone after the uninstallation.

b) I re-installed only the MAIN plugin.

c) From the front-end I registered selecting a subscription that provides a free trial. After coming back from Paypal, the subscription was INACTIVE and didn't allow me to sign-in as it was asking me to pay.

2. a) I uninstalled CBSubs 1.0.2 again and reinstalled CBSubs 1.0.1 (only the MAIN plugin).

b) From the front-end I registered selecting a subscription that provides a free trial. After coming back from Paypal, the subscription was successfully Activated and I was able to login!

Could the developers please check this and fix it ASAP? This is truly a big issue.

In the meantime, is it safe if I install the email plugin (cbplug_int_cbsubsemail-E.zip) that comes with CBSubs 1.0.2 into my 1.0.1 installation?
(This because the emails are not sent in 1.0.1 and this was fixed in 1.0.2).

Regards,

Carlos

Please Log in to join the conversation.

12 years 4 months ago #105401 by krileon
Yes it's safe to use CB 1.0.2 plugins with CBSubs 1.0.1, but you will get a message indicating version mismatch. Just ignore this.

Bug is confirmed, but we have some development off on vacation. So fix is approx. 2 weeks, but rest assured it will be fixed. In the mean time those that desperately need this functionality please revert to CBSubs 1.0.1.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 4 months ago #105421 by nant
carlosleon0615 wrote:

I'm sorry I don't think I understand what you mean with "It's advised not to revert to an older version" and with "replace all the files in the same manor you upgraded to 1.0.2.".

I followed Beat's installation instructions on this post:
CBSubs 1.0.2 Released!

Should I do exactly the same as above (but using 1.0.1)? This means NOT uninstalling most plugins but simply reinstalling version 1.0.1 on top.

I'm also using JoomlaPack and I was thinking of reverting to a backup I made before upgrading to 1.0.2 using JoomlaPack's restoration method.
Is this what is Not recommended?


1.0.2 doesn't introduce any database changes, so you can "upgrade" to 1.0.1 same way as you did upgrade to 1.0.2.

If you do this, please tell us if it solves your problem as this would be a regression from 1.0.1. Thank you

Please Log in to join the conversation.

12 years 4 months ago #105524 by carlosleon0615
Replied by carlosleon0615 on topic Re:HUGE ISSUE: Account & Subscription NOT Activated!
nant wrote:

1.0.2 doesn't introduce any database changes, so you can "upgrade" to 1.0.1 same way as you did upgrade to 1.0.2.

If you do this, please tell us if it solves your problem as this would be a regression from 1.0.1. Thank you

Good to know that "downgrading" from 1.0.2 to 1.0.1 is as simple as when performing an upgrade (this is, no need to first uninstall).

Since I was not sure, I actually uninstalled 1.0.2 and then installed 1.0.1. And yes, 1.0.1 works correctly (as I mentioned in my previous post), while 1.0.2 exhibits the problem with free trials.

Looking forward to the fix.

Regards,

Carlos

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.206 seconds

Facebook Twitter LinkedIn