CB 1.3 and AEC

8 years 11 months ago #147403 by jstec
I know I probably should look at upgrading to CBSubs, but...

Does anyone know if AEC will work with CB 1.3? The following paragrapgh in the CB 1.3 README-UPGRADE.txt file has me concerned:

IMPORTANT - This component does not work with any other registration or
login modules or hacks. It is recommended that you uninstall all such
modifications as the effects of using them with this component are
unknown.


Thanks
8 years 11 months ago #147411 by nant
Your best approach would be to ask about this on the AEC forums.
8 years 11 months ago #147627 by jstec
Yes, I cross-posted to both (after seeing if it was already asked and answered, of course). What got me concerned was the CB disclaimer. Was something relative to registration changed, or is that just a standard disclaimer so that you don't have to support every one-off registration scheme there is?

Thanks,

Jeff
8 years 11 months ago #147635 by nant
jstec wrote:

Yes, I cross-posted to both (after seeing if it was already asked and answered, of course). What got me concerned was the CB disclaimer. Was something relative to registration changed, or is that just a standard disclaimer so that you don't have to support every one-off registration scheme there is?

Thanks,

Jeff


Sorry, I am not aware of this CB disclaimer? Maybe a URL we can read?

Also - heads up for you - there is a CBSubs 25% off promotion which ends today - might want to take advantage of it ...
8 years 11 months ago #147668 by Kolibri
I use AEC and CB. The support of AEC had a lot of work and trouble with implementing AEC and CB 1.2.3 on my website. There were strange unexpected logical errors in CB registrations fields. After upgrading to CB 1.3 I got follwing comment by AEC:

"Last weekend, I had spent over 20 hours debugging the registration/subscription process with AEC and CB. ... I got everything to work except for date fields during registration. Then on Monday, low and behold, I see CB has version 1.3 out, so I upgraded our dev servers tot hat, and everything i had debugged was now working, except once again for a date field on registration.

If you place a date field on registration and make it required, it fails, if it is not required, CB accepts the date, it evens hows in the debug code, but does not save the date. ... not to use date fields during
the registration process. You can redirect the user on first login to ... edit their profile, and make the fields required there, so they fill them out after the first time they log in."

So AEC will work with CB from my view, but you should aware to use more than name, adress, username and password as registration fields and be careful with required fields. You will kill the registration/subscription process iE with setting a text area field as not required but with minimum text length. Setting a minimum textlength may be allowed with setting field as required at the same time.

I think you should ask for assistance by AEC support before upgrading to CB 1.3.

Post edited by: Kolibri, at: 2010/12/03 14:56
8 years 11 months ago #147683 by nant
Kolibri wrote:

If you place a date field on registration and make it required, it fails, if it is not required, CB accepts the date, it evens hows in the debug code, but does not save the date. ... not to use date fields during
the registration process. You can redirect the user on first login to ... edit their profile, and make the fields required there, so they fill them out after the first time they log in."


CB Date field required during registration works just fine - just tested it.

If you can should me a clean CB 1.3 environment (without AEC) that has such I problem I will take a look at it.
Moderators: beatnantkrileon
Time to create page: 0.451 seconds