[#2906] problem with the plug_cbgroupjive directory

12 years 6 months ago - 12 years 6 months ago #179264 by dryas
when someone create a new group and define a logo, groupjive create a new directory in /images/comprofiler/plug_cbgroupjive.

The directory is created with the rights 744, i must correct manualy each new created directory, i don't have this sort of problem with other component.

on my os umask is set to 0022
on my ftp daemon umask is set to 0022
if i create or transfert a directory via FTP, the right is correct (755)

I don't find where the 744 is configured.

the joomla ftp layer is enabled.

Please Log in to join the conversation.

12 years 6 months ago #179376 by krileon
This is fixed with release of GJ 2.4, please upgrade if you have not done so already. It will use the Joomla parameter "dirperms" (believe J1.5/J1.6/J1.7 don't have this) and if it can't find such parameter it'll use 0755. Previous releases of GJ 2.x forced 0744.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 6 months ago #179478 by dryas
i m under GJ 2.4
where is set the dirperms parma ?

Please Log in to join the conversation.

12 years 6 months ago #179491 by krileon
dirperms is only present in Mambo and J1.0. Sense it's not present in J1.5/J1.7 then GJ falls back to 0755. You're welcome to review the source at cbgroupjive.class.php and make any changes you like, but there's likely something configured on your server not letting it use 0755. Are the sub-folders of images/comprofiler/plug_cbgroupjive/ being created as 0755? If so then I suspect there's a problem with mkdir and folder1/folder2/ usage causing folder1/ not to be given the mode specified.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 6 months ago #179629 by dryas
no the subfolders are created with as 744
I fiwed temporarly the problem with a cron.
I ll check the class

i ll try with a joomla 1.7 and the problem is the same.

Please Log in to join the conversation.

12 years 6 months ago #179665 by krileon
Strange, have created a bug ticket for further investigation for next release. Have also added to the ticket to allow specifying your own permissions via backend configuration.

forge.joomlapolis.com/issues/2906


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.192 seconds

Facebook Twitter LinkedIn