[SOLVED] Subscription Membership Options not being proposed

2 years 2 months ago - 2 years 2 months ago #270627 by cjmicro
Since I can't use CB 2 and CBSUBS 4 I had to roll back to CB 1.9 and CBSUBs 3 on my new site.

Everything came through ok (copied exactly) but now I can't get it to propose the options to anyone on front end OR back end. It only shows their subscription. I have checked all options on plans and they are all the same, but no proposal of other plans for me to choose on front or back.

I hate to be such a pain but we are trying to get our site up to J3 and CBsubs is the holdup.
New site (j 3.4.4 cb 1.9.1 cbsubs 3.0) shows this
Your Subscriptions
userX's current and past subscription
Active subscription Electronic Subscription
1 year Active, expiring on 05/06/2016
Unsubscribe Delete

Old Site (j 1.5.26 cb 1.9.1 cbsubs 3.0) shows this
Your Subscriptions
USERX's current and past subscription
Active subscription Risk-Free Subscription
1 year Active, expiring on 05/06/2016
Unsubscribe Delete
Current subscription options:
Comp Full Subscription
Free per 10 years.
None
Lifetime Subscription for Free


Any ideas what is different?
2 years 2 months ago #270719 by nant
2 years 2 months ago - 2 years 2 months ago #270853 by cjmicro
I can't use CB 2 and subs 4 becuase of the content/category protection bug. I already had 2.0 installed and all my new plans set up, but the content/category protection didn't work so i had to UNINSTALL all that and reinstall 1.9 and cbsub 3. I have a ticket regarding this here: www.joomlapolis.com/forum/153-professional-member-support/231084-5508-cbsubs-content-protection-not-showing-text-before-readmore?start=6

I turned on error reporting and this is what comes up.
Notice: Undefined offset: 1 in <span>/</span>home<span>/</span>nxxxx/public_html/newsite/components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/plugin/cbsubscontent/cbsubs.content_access.php on line 916

Do you think this could be the problem?

I don't think it is because wehn i delete the cbsubs content plugin the error goes away and the subscriptions still don't present themselves in the profile or on back end to change.
2 years 2 months ago - 2 years 2 months ago #271196 by cjmicro
I upgraded to CB Subs 4.01 and CB 2.1.1 (nightly releases) and I am still having this problem. No plan options are proposed in the front end OR the back end for me to change them. Normally it shows a list of available plans that you can choose.

I want people to be able to upgrade to the new plans when I add them but right now it's not giving ANY options to choose a plan. It only shows the plan you have, nothing to "choose" in the profile/subscription tab, or on the back end in admin.

Can you help me with this? PLEASE!!!

I sent you a PM with superadmin login.
2 years 2 months ago #271205 by nant

cjmicro wrote: I can't use CB 2 and subs 4 becuase of the content/category protection bug. I already had 2.0 installed and all my new plans set up, but the content/category protection didn't work so i had to UNINSTALL all that and reinstall 1.9 and cbsub 3. I have a ticket regarding this here: www.joomlapolis.com/forum/153-professional-member-support/231084-5508-cbsubs-content-protection-not-showing-text-before-readmore?start=6

I turned on error reporting and this is what comes up.
Notice: Undefined offset: 1 in <span>/</span>home<span>/</span>nxxxx/public_html/newsite/components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/plugin/cbsubscontent/cbsubs.content_access.php on line 916

Do you think this could be the problem?

I don't think it is because wehn i delete the cbsubs content plugin the error goes away and the subscriptions still don't present themselves in the profile or on back end to change.


The content category protection bug has been fixed with latest CBSubs 4.0.1 nightly release that you can download from here:
www.joomlapolis.com/component/docman/doc_details/671-cbsubs-gpl-nightly-build
2 years 2 months ago - 2 years 2 months ago #271233 by cjmicro
Thanks for the note. the bug fix helps the problem with text not showing with readmore for category blog. However, it does not help with my subscriptions not being proposed.

When you view your subscriptions it shows your current or past subscriptions, but does not propose any of the other plans. This is/was not the case on the old site using cb 1.9 and CBsubs 3. It is the same server, i am working with an upgrade in a new folder.

I PMed you superadmin login, please help. I cannot go live without this working. Thank you.

On another site with CB2.1 and CBsubs 4.01 it does work properly, so it's something on this site! I turned on error reporting and i do not get that offset error as I do on this site by the way.
Moderators: beatnantkrileon
Time to create page: 0.189 seconds
Facebook Twitter Google LinkedIn