users redirected to com_user on timeout

11 years 7 months ago #61023 by davidbrent
Hi I'm currently using community builder in a 1.5 joomla install. I've disabled the mod_cblogin completely and it doesn't appear anywhere on my site.

My problem is when users timeout, they're redirected to index.php?option=com_user&view=login instead of com_comprofiler.

I can't find where to edit this? Thanks for any help or suggestions.

Post edited by: davidbrent, at: 2008/04/15 20:49
11 years 5 months ago #66247 by nwood888
I'm having this same issue. Anyone have a fix?
11 years 4 months ago #68937 by kevincam
I too am having this problem and looking for a fix. Hope someone has an answer.
11 years 2 months ago #74869 by visualstar
Is there a solution for this ???
The CB Team should figure this out in a couple of minutes, not ?
11 years 2 months ago #74876 by visualstar
I found a solution...

Maybe not the most proper one but still...

I've located the php page where joomla checks witch page to call up when there is no user logged in at the moment.

joomlaroot/includes/application.php

On line 184 and 209 you can edited this link.

In my case I just placed this link: index.php?option=com_comprofiler&task=

Then I just changed the error message in my language file so it says: "You have to login or register on our site to view the requested page."

Like I said, it's maybe not the best way but users can't use the wrong login module when they are clicking a link via for example a email message.

Any comments from the CB Team ?
11 years 2 months ago #74895 by nant
I believe that there is a mambot (plugin) that redirects such URLs to the CB registration.

Please search on Joomla extensions directory.
Moderators: beatnantkrileon
Time to create page: 0.449 seconds

Facebook Twitter LinkedIn