Direct Access to this location is not allowed.

13 years 1 week ago #97837 by Rapunzl
Joomlageek2.0 wrote:

I am going to venture a guess and let someone with more skills confirm or deny the issue.
Everything on my new site is 1.5 native.
I'm not sure why legacy mode fixes it... but it does. I would like to speculate but being ignorant of what legacy mode does, I cannot be certain.
I believe that what is happening has to do with how files are being pointed. I say this because several said that they were upgrading their sites and if they are like me, they created a new IP address and began building the site on the new IP address. Using the IP address, instead of a www address, may be leading to the: "Direct Access to this location is not allowed."
Hey...it is only a guess.

Ken

Are you using 1.2 stable or RC? PHP version x.x.x? Profile Gallery version? Have you disabled all extensions and CB plugins one-by-one, testing inbetween to see which is causing the error?

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction

Please Log in to join the conversation.

13 years 1 week ago #97847 by Joomlageek2.0
Replied by Joomlageek2.0 on topic Re:Direct Access to this location is not allowed.
Problem Description:
I have installed an all new Joomla 1.5.10 installation with no legacy components. When I attempt to add a field in CB 1.2 stable, I receive the error message below.


Log/Error Message:

Direct Access to this location is not allowed

Actions Taken To Resolve:
Switching to legacy mode per the suggestions on the board enabled me to add the fields into Community Builder.

Diagnostic Information
Joomla! Version: Joomla! 1.5.10 Production/Stable [ Wohmamni ] 27-March-2009 23:00 GMT
configuration.php: Writable (Mode: 644 ) | RG_EMULATION: N/A
Architecture/Platform: Linux 2.6.26.5-SMP2 ( i686) | Web Server: Apache/1.3.37 (Unix) mod_throttle/3.1.2 FrontPage/5.0.2.2635 mod_psoft_traffic/0.2 mod_ssl/2.8.28 OpenSSL/0.9.8b ( 98.131.65.129 ) | PHP Version: 5.2.3
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Not Writable[color] | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 5.0.41-community-log ( mysql305.ixwebhosting.com via TCP/IP )

Please Log in to join the conversation.

13 years 1 week ago #97850 by Rapunzl
Your error message indicates something is legacy, so again, try disabling each extensions and CB plugin, testing inbetween to find the cause and remedy.

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction

Please Log in to join the conversation.

13 years 1 week ago #97858 by adam@littledonkey.net
Replied by adam@littledonkey.net on topic Re:Direct Access to this location is not allowed.
Well, this was happening in both admin and frontend so not sure it was to do with the template.

Anyhow, I uninstalled everything (the plugins that were causing the error), then reinstalled one at a time testing each time and I didn't get the error message again.

Legacy plugin enabled though, for now.

www.joomlapolis.com/components/com_joomlaboard/emoticons/shocked.png

Edit: Actually my problem was that after I enabled legacy mode I couldn't save a CB user profile. Doing the above fixed that as well!!

Post edited by: adam@littledonkey.net, at: 2009/05/06 20:48

Please Log in to join the conversation.

13 years 1 week ago #97859 by Joomlageek2.0
Replied by Joomlageek2.0 on topic Re:Direct Access to this location is not allowed.
Rapunzl wrote:

Your error message indicates something is legacy, so again, try disabling each extensions and CB plugin, testing in between to find the cause and remedy.


I was in legacy mode. That is the only way I could add fields.

Post edited by: Joomlageek2.0, at: 2009/05/06 20:54

Please Log in to join the conversation.

13 years 1 week ago #97868 by Joomlageek2.0
Replied by Joomlageek2.0 on topic Re:Direct Access to this location is not allowed.
I tried three time to post an extended diagnostic with the legacy mode disabled. It would not post. Is there a length limit on these posts?

Rapunzl wrote:

Your error message indicates something is legacy, so again, try disabling each extensions and CB plugin, testing in between to find the cause and remedy.


I was in legacy mode. That is the only way I could add fields.
So...here is the extended diagnosis report with legacy mode disabled.

Problem Description:
I have installed an all new Joomla 1.5.10 installation with no legacy components. When I attempt to add a field in CB 1.2 stable, I receive the error message below.

Log/Error Message:

Direct Access to this location is not allowed

Actions Taken To Resolve:
Switching to legacy mode per the suggestions on the board enabled me to add the fields into Community Builder.
In trying to further diagnose the problem I have turned off legacy mode.

Diagnostic Information
Joomla! Version: Joomla! 1.5.10 Production/Stable [ Wohmamni ] 27-March-2009 23:00 GMT
configuration.php: Writable (Mode: 644 ) | RG_EMULATION: N/A
Architecture/Platform: Linux 2.6.26.5-SMP2 ( i686) | Web Server: Apache/1.3.37 (Unix) mod_throttle/3.1.2 FrontPage/5.0.2.2635 mod_psoft_traffic/0.2 mod_ssl/2.8.28 OpenSSL/0.9.8b ( 98.131.65.129 ) | PHP Version: 5.2.3
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5): Yes | iconv Support (1.5): Yes | save.session_path: Not Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 5.0.41-community-log ( mysql305.ixwebhosting.com via TCP/IP )

Post edited by: Joomlageek2.0, at: 2009/05/06 21:15

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.156 seconds

Facebook Twitter LinkedIn