Skip to Content Skip to Menu

Content plugin not doing his job

  • amazeika
  • amazeika
  • OFFLINE
  • Posts: 132
  • Thanks: 0
  • Karma: 6
14 years 10 months ago #105038 by amazeika
Replied by amazeika on topic Re:Content plugin not doing his job
mmm, now that I think about it, this was the only config change that was missing after the upgrade and normally even if you uninstall any extension the database info still remains.

I would lost everything otherwise.

Arunas Mazeika
WeXtend.com - Professional development for Joomla!.

Please Log in or Create an account to join the conversation.

  • amazeika
  • amazeika
  • OFFLINE
  • Posts: 132
  • Thanks: 0
  • Karma: 6
14 years 10 months ago #105087 by amazeika
Replied by amazeika on topic Re:Content plugin not doing his job
Have you tried the "READ: By Content Section" with "Also control the Content Section/Categories Lists: Yes" and "READ: By Content Category with Also control the Content Categories Lists: Yes" in the "For read access" zone of the content plugin ?.

I'm trying to hide the list of articles of a category and they still appear, same thing with a category list from a section menu item.

I believe that this option set to yes will avoid the article/categories lists from being displayed, right ?

Arunas Mazeika
WeXtend.com - Professional development for Joomla!.

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68613
  • Thanks: 9109
  • Karma: 1434
14 years 10 months ago #105099 by krileon
Replied by krileon on topic Re:Content plugin not doing his job
I believe this maybe a misunderstanding. You need to have the menu link protect as well:

...For content sections blogs, please use the corresponding menu item below to control them.

Will require further investigation or clarification.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

  • amazeika
  • amazeika
  • OFFLINE
  • Posts: 132
  • Thanks: 0
  • Karma: 6
14 years 10 months ago #105113 by amazeika
Replied by amazeika on topic Re:Content plugin not doing his job
Yes, I think that should be clarified. What I did is to protect the category view through URL in the extension integration tab and that works as expected.

In Settings -> Integrations -> Content/Extensions -> Articles access

This is also unclear unless you carefully read the tooltip. In article access you have Still show intro text for articles: Yes/No. Regardless of the answer you suppose that the entire article wont show if it's protected. The question that is being asked here is only about the intro part of the article and not the article itself. Is actually the tooltip that tells you that if you chose No the entire article won't show, which is confusing.

Arunas Mazeika
WeXtend.com - Professional development for Joomla!.

Please Log in or Create an account to join the conversation.

14 years 8 months ago #109444 by taxsaleuniversity
Replied by taxsaleuniversity on topic Re:Content plugin not doing his job
Is this something that changed with the upgrade? I've got a site that hides one category out of two in the section blog layout with just read access restricted for that one category. No menu access restrictions, even have 'show intro' set to 'yes' and it hides the category perfectly.

I just set up a new site and this is not functioning the same way- shows the whole category even though read access should not allow it.

thanks-

Please Log in or Create an account to join the conversation.

  • krileon
  • krileon
  • ONLINE
  • Posts: 68613
  • Thanks: 9109
  • Karma: 1434
14 years 8 months ago #109446 by krileon
Replied by krileon on topic Re:Content plugin not doing his job
taxsaleuniversity wrote:

Is this something that changed with the upgrade? I've got a site that hides one category out of two in the section blog layout with just read access restricted for that one category. No menu access restrictions, even have 'show intro' set to 'yes' and it hides the category perfectly.

I just set up a new site and this is not functioning the same way- shows the whole category even though read access should not allow it.

thanks-


Ensure you're not testing the protection with a super admin account as super admins ignore protection. Use standard logged in user without subscription or remain logged out when running protection tests.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in or Create an account to join the conversation.

Moderators: beatnantkrileon
Powered by Kunena Forum

Facebook Twitter LinkedIn