HUGE ISSUE: Account & Subscription NOT Activated!

12 years 4 months ago #105110 by carlosleon0615
I just upgraded to CBSubs 1.0.2 and now I have a HUGE problem.

CBSubs is configured NOT to allow free registered users. My plans are set up as auto-recurring and the first 3 days are for free.

After user returns from Paypal (1st payment of $0.00), the "Registration Complete" and the Thank You message correctly appear on the site. Paypal correctly sends the Subscription Receipts to both the user and the site admin and you can see the subscription active on the Paypal site.

However, when user tries to login, it says that "An active membership is needed for access" and the subscription appears as NOT having been paid!!

Furthermore, their account remains Disabled and No Emails are sent: No Community Builder email sent on registration and NO CBSubs emails sent on Activation (the ones configured under the Presentation tab of any plan).

This used to work correctly in CBSubs 1.0.1.

PLEASE HELP!

Carlos
P.S. I have Joomla 1.5.12, CB 1.2.1 and CBSubs 1.0.2
My site: www.everybodycansalsa.com

Post edited by: carlosleon0615, at: 2009/07/16 09:02

Post edited by: carlosleon0615, at: 2009/07/16 09:13

Please Log in to join the conversation.

12 years 4 months ago #105131 by krileon
Set Allow Free Registered Users (without subscriptions) that NO and Create Subscriptions also for free lifetime plans to YES then make your plan default.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 4 months ago #105149 by carlosleon0615
Replied by carlosleon0615 on topic Re:HUGE ISSUE: Account & Subscription NOT Activated!
Hi Krileon,

Thanks for trying to help. I already had those exact settings!!
As far as making the plan the default one, well, I have 3 plans and of course only 1 of them is set as the default one.
Whether the user subscribes to the default one or any other, the account does NOT get activated anymore in CBSubs 1.0.2.

As I mentioned this was working correctly right before I upgraded to 1.0.2 and I didn't make any changes to the plans or global settings.

Please help as this is a pretty big deal.

Thanks,

Carlos
P.S. You can easily reproduce it by trying it yourself on my site. Select the "Daily Subscription" that has 1 Free-Day trial and then $0.10 (this is just a test plan).
everybodycansalsa.com/Create-an-account.html

Please Log in to join the conversation.

12 years 4 months ago #105165 by krileon
Have you made sure to setup paypal payment gateway correctly so the flags from paypal are sent to the correct site?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 4 months ago #105166 by carlosleon0615
Replied by carlosleon0615 on topic Re:HUGE ISSUE: Account & Subscription NOT Activated!
Yes. As I said, it was working correctly with CBSubs 1.0.1. I didn't change anything in Paypal or in my plans.

Furthermore, after completing the Paypal process, user gets automatically redirected to the site AND the Thank You messages appear.

Isn't all the above an indication that Paypal is correctly re-directing to my site?

Haven't you been able to reproduce it on your side?
Can someone take a look at my site?

Thanks,

Carlos

Please Log in to join the conversation.

12 years 4 months ago #105167 by krileon
Do you have e-mail confirmation or moderator approval set for users and have you approved them? Subscriptions won't become active if the user isn't active.

Was funds actually draw from the user, how many users is this affecting?

I am not able to duplicate your issue. All my subscriptions are going through fine.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.204 seconds

Facebook Twitter LinkedIn