Problems with subscriptions after upgrade

14 years 8 months ago #108095 by ZombieNRG
Hi I have three rather big problems at the moment. Thank you for your help in advance.

1) I have 2 subscription plans at the moment.
(Neither is set to default. Both are free.) 1 for businesses and 1 for artists.

Problem: selecting either plan results in the person being signed up as a business. Changing subscription in the subscriptions tab of the CB profile has no effect.


2) Users do Not show up under subscriptions. (CB Paid Subscriptions.)

I imported 140+ users into the Business plan. It reported success. No one shows up under Subscriptions.
except 3 users who signed up in 1.0.1.

3) The Subscription tab (on Admin side, CB user manager) does not show second plan. Everyone shows up as a business plan member. No option to change plan and they don't show up in Paid Subscriptions.

Thank you for your help,
Eric

Post edited by: ZombieNRG, at: 2009/08/14 23:28

Please Log in to join the conversation.

14 years 8 months ago #108115 by krileon
Replied by krileon on topic Re:Problems with subscriptions after upgrade
From your previous posts and sounds of this thread you're installation is possibly corrupt. Have you tried a fresh install to see if issue is related to your install (this will help confirm CBSubs bug or not)?


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

14 years 8 months ago #108157 by ZombieNRG
Replied by ZombieNRG on topic Re:Problems with subscriptions after upgrade
Hi krileon,
2 completely fresh installs yesterday trying to deal with the .htaccess lockout issue.

Double checked my dedicated server:
Linux 2.6.22, Apache 2.2.11, MySQL 5.0.27, PHP 5.2.9, Plesk 9.2

Order of events.
1) 1.0.1 up and running fine
2) set up two sub plans
Business and Artist - both Free
Business is default
Artists have access to Ignite Galleries
3) 3 new users signed up
they show up as active subscriptions
4) Tried to import the other 136 users
Success reported. However they show up as "active registrations" on the icon and do not appear in the subscriptions list.
5) Updated to 1.0.2 as per your instructions in the Forums since no read me file came with the update.
6) Had problems with a directory not being deleted on uninstall.
7) Manually deleted directory(FTP) reinstalled
8) reported success on all installs

Lots of Big Problems ensue.

9) Uninstalled and reinstalled everything
10) Ran CB Tools - green across the board.

11) Tried it a second time Just in Case.

Still no Luck.

Any thoughts or help?

Please Log in to join the conversation.

14 years 8 months ago #108189 by krileon
Replied by krileon on topic Re:Problems with subscriptions after upgrade
Did you ensure your import was a LIVE import. Navigate to CBSubs then Import and ensure Import: is YES. First edit a user who was meant to have the subscription then check their subscription tab to ensure they DON'T have the subscription. If they do not use the import feature again ensuring they're not using the test import feature.

It can report success for 0 users, ensure you've properly selected what users to import, either by file just ACL. If by file ensure the file is built properly with no errors as this can cause the import to not import all users.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

14 years 7 months ago #108719 by ZombieNRG
Replied by ZombieNRG on topic Re:Problems with subscriptions after upgrade
Hello again,
Yes I did it just the way I was instructed. see #1 below.

I can now set up user accounts.
I went for pretty much a shotgun approach to get this working. So unfortunately I can't post "the solution" here. Which is really annoying.

Here's what I think is happening/happened.

1) Settings/Global/registration settingin/Create subscriptions also for free lifetime plans was set to "no" --- I hadn't set up plans until after 140 people had signed up.

I believe this stops the importing of users (ACL registered users) into a Plan. It just causes them to be listed as "Active registrations".

Can you Confirm that?


2) As for why no one could sign up for the Artist plan. I have no idea what was happening. I've tested 3 different scenarios and I can't reproduce the problem anymore. Before - I couldn't sign Anyone up on the Artist plan from the front or back.

Could this possibly have anything to do with Not making the 2 Main(Parent) Plans Exclusive?

Please Log in to join the conversation.

14 years 7 months ago #108749 by krileon
Replied by krileon on topic Re:Problems with subscriptions after upgrade
I'm not sure, I didn't examine your installation so wouldn't know how you set your installation up.

CBSubs is a massive plugin and should be taken with a shotgun approach; take it slow and read the documentation very very carefully.

Enabling the need for free plans is fine, but you then need to provide a free plan.

If you disable free plans, then enable free registered users.

If you want no free users then set both to no.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.270 seconds

Facebook Twitter LinkedIn