[SOLVED] ERROR cbplug_CBSubs_MAIN_102-E install

12 years 2 months ago #110184 by mjsplant
Help,

First, I have read in the documentation regarding the install of CSubs. This is a new site, and had AEC working but have since removed it because the VirtueMart component was not syncing with CB. Also removed the VM components.

I decided to purchase CSUBS 1.0.2 for both the purchasing of a subscription upon registering and for the sales of merchandise.

Upon installing the cbplug_CBSubs_MAIN_102-E.zip CB plugin, I received the following error message after clicking the install button.

"
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122280 bytes) in /[root directory]/content/components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/cbpaidsubscriptions.php on line 0"

This was on a blank web page.

I pressed the refresh browser key (just to see what would happen) and I was returned to a joomla page that stated "Upload showPlugins - Failed" in bold. And the following message below that:

"Another plugin is already using directory: "/[root directory]/contents/components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/"

I clicked on the "Continue" link and was brought back to the CB plugins page, where the "CB Paid Subscriptions" plugin was listed.

I clicked on it, (to see what would happen) and received the following):

"Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /[root directory]/content/components/com_comprofiler/plugin/user/plug_cbcore/cb.core.php on line 1740"

What do I do?

FYI (a few more notes)

I was able to install a couple of the other plugins and was able to click through to their plugin editing pages.

I decided to then uninstall the plugins in reverse order. All Successfully.

I checked to see if the directory "/[root directory]/contents/components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/" existed it, and deleted it, as it was. However, I am confident it was not their when I initially attempted the install.

I tried it again and received the exact same messages.

Also PHP configuration is as follows:

1)PHP Version 5.2.42
2)This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
with eAccelerator v0.9.5.3, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
with the ionCube PHP Loader v3.1.33, Copyright (c) 2002-2007, by ionCube Ltd., and
with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies

3)mysql 5.0.75

4)OpenSSL 0.9.8g 19 Oct 2007

5) Joomla! 1.5.14 Stable

6) Apache server

7) CB 1.2.1 (Latest version - downloaded 2 days ago)

I would appreciate any help. I am in a bind, and might have to scrap CB if I can't get this up very quickly.

One more note: I know the CSubs documentation indicated that the Joomla FTP needed to be enabled, however, I have had to disable it as there seems to be somesort of problem. I could not install any plugins or components (non CB) with it enabled. With it disabled, all installations of any Plugins, Modules or Components (worked fine).

Thank you in advance.

Regards
Matt

Post edited by: mjsplant, at: 2009/09/04 00:58

Post edited by: krileon, at: 2009/09/04 14:26

Please Log in to join the conversation.

12 years 2 months ago #110186 by Rapunzl
Have you read the FAQ and Help Us Help You? You did give a lot of info, to your credit... and without knowing the results of the suggestions above, I can say you are using an old version of PHP, even if it is 5. 5.6 is suggested and the latest version, 5.9, is always best.

Jamie (Rapunzl)
Community Builder Team Member

Before posting on forums: Read all CB Articles | Specially the FAQ | Help us help you
CB links: Subscribe to CB documentation | [url=http://www.joomlapolis.com/content/view/7363/37/
]Our templates[/url] | [url=http://www.joomlapolis.com/content/blogcategory/61/74/
]Paid Subscriptions[/url] | Get Hosting | Our Forge
Visit my CB Profile

My personal site Rapunzl's Reality always under reconstruction

Please Log in to join the conversation.

12 years 2 months ago #110188 by mjsplant
According to the documentation, which granted keeps refering to 1.0.1, not 1.0.2, it say the requirements for CSubs is as follows, with regards to PHP

"PHP version 5 or better (recommended PHP version 5.2.3 or better)"

And as I mentioned I am using 5.2.42

As always, thanks in advance,

Matt

Please Log in to join the conversation.

12 years 2 months ago #110189 by mjsplant
My apologies, I did not answer your first question.

I did read them, and search vigorously for anything on the site. Alas, to no avail.

Regards,

Please Log in to join the conversation.

12 years 2 months ago #110192 by krileon

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122280 bytes) in /[root directory]/content/components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/ cbpaidsubscriptions.php on line 0"


You need to increase your memory site limit. Standard issue covered in FAQ, please read the Help us help you found in my signature.

"Another plugin is already using directory: "/[root directory]/contents/components/com_comprofiler/plugin/user/plug_cbpaidsubscriptions/"


Navigate to components/com_comprofiler/plugin/user/ and delete the folder plug_cbpaidsubscriptions. This happens on a partial install due to you running out of memory.


Kyle (Krileon)
Community Builder Team Member
Before posting on forums: Read FAQ thoroughly + Read our Documentation + Search the forums
CB links: Documentation - Localization - CB Quickstart - CB Paid Subscriptions - Add-Ons - Forge
--
If you are a Professional, Developer, or CB Paid Subscriptions subscriber and have a support issue please always post in your respective support forums for best results!
--
If I've missed your support post with a delay of 3 days or greater and are a Professional, Developer, or CBSubs subscriber please send me a private message with your thread and will reply when possible!
--
Please note I am available Monday - Friday from 8:00 AM CST to 4:00 PM CST. I am away on weekends (Saturday and Sunday) and if I've missed your post on or before a weekend after business hours please wait for the next following business day (Monday) and will get to your issue as soon as possible, thank you.
--
My role here is to provide guidance and assistance. I cannot provide custom code for each custom requirement. Please do not inquire me about custom development.

Please Log in to join the conversation.

12 years 2 months ago #110199 by mjsplant
Thank you. I was able to adjust and it installed fine.

Regards

Please Log in to join the conversation.

Moderators: beatnantkrileon
Time to create page: 0.199 seconds

Facebook Twitter LinkedIn